aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2007-03-04 19:12:37 +0000
committerJuergen Lock <nox@FreeBSD.org>2007-03-04 19:12:37 +0000
commit222105d2f879f97c6cc1e105e287760153ee989f (patch)
treefd2f0edf84388be707f55ce8bba41925a3690001 /security/openvpn
parentd4c181f21b213826fb7f478a7330ed6433444cfa (diff)
downloadports-222105d2f879f97c6cc1e105e287760153ee989f.tar.gz
ports-222105d2f879f97c6cc1e105e287760153ee989f.zip
Notes
Diffstat (limited to 'security/openvpn')
-rw-r--r--security/openvpn/Makefile10
-rw-r--r--security/openvpn/files/openvpn.sh.in22
2 files changed, 16 insertions, 16 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index bfe7f7c34c4c..c8d8572b19f4 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -7,13 +7,13 @@
PORTNAME= openvpn
# -----------------------------------------------------
-# DO NOT BOTHER TO SEND NOTICES ABOUT 2.0.9 AS IT FIXES
-# WINDOWS-ONLY BUGS THAT DON'T AFFECT *BSD AND THUS
-# DOES NOT WARRANT A PORT UPGRADE! AND UPGRADE REQUESTS
-# WILL BE DROPPED.
+# DO NOT BOTHER TO SEND NOTICES ABOUT OPENVPN 2.0.9
+# AS IT FIXES WINDOWS-ONLY BUGS THAT DON'T AFFECT *BSD
+# AND THUS DOES NOT WARRANT A PORT UPGRADE!
+# UPGRADE REQUESTS WILL BE DROPPED UNLESS BSD-RELATED.
# -----------------------------------------------------
PORTVERSION= 2.0.6
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= security net
# MASTER_SITES points to hosts in distinct data centers,
# so just one MASTER_SITES entry should be OK.
diff --git a/security/openvpn/files/openvpn.sh.in b/security/openvpn/files/openvpn.sh.in
index 54b710c47626..569dfb5d802f 100644
--- a/security/openvpn/files/openvpn.sh.in
+++ b/security/openvpn/files/openvpn.sh.in
@@ -2,10 +2,10 @@
#
# openvpn.sh - load tun/tap driver and start OpenVPN daemon
#
-# (C) Copyright 2005 by Matthias Andree
+# (C) Copyright 2005 - 2007 by Matthias Andree
# based on suggestions by Matthias Grimm and Dirk Gouders
-#
-# Made in Northrhine-Westphalia, Germany
+# with multi-instance contribution from Denis Shaposhnikov, Gleb Kozyrev
+# and Vasil Dimov
#
# $FreeBSD$
#
@@ -64,17 +64,17 @@
. %%RC_SUBR%%
case "$0" in
- /etc/rc*)
+/etc/rc*)
# during boot (shutdown) $0 is /etc/rc (/etc/rc.shutdown),
# so get the name of the script from $_file
- name=$(basename "$_file")
+ name=$(basename "$_file" .sh)
;;
- *)
- name=$(basename "$0")
+*)
+ name=$(basename "$0" .sh)
;;
esac
-rcvar=`set_rcvar`
+rcvar=$(set_rcvar)
prefix="%%PREFIX%%"
@@ -122,9 +122,9 @@ eval ": \${${name}_if:=\"\"}"
eval ": \${${name}_configfile:=\"${prefix}/etc/openvpn/${name}.conf\"}"
eval ": \${${name}_dir:=\"${prefix}/etc/openvpn\"}"
-configfile="`eval echo \\${${name}_configfile}`"
-dir="`eval echo \\${${name}_dir}`"
-interfaces="`eval echo \\${${name}_if}`"
+configfile="$(eval echo \${${name}_configfile})"
+dir="$(eval echo \${${name}_dir})"
+interfaces="$(eval echo \${${name}_if})"
required_files=${configfile}
command_args="--cd ${dir} --daemon --config ${configfile} --writepid ${pidfile}"