aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-01-11 23:09:37 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-01-11 23:09:37 +0000
commit51939c51c12e7a7bfed557c620068da8eedb6062 (patch)
tree5b6711e0f4cc89a423ea6559a20d4d19cab2939b /security/openvpn
parentabd0c3f1f40121fd49302a2550935a671dee3ecb (diff)
downloadports-51939c51c12e7a7bfed557c620068da8eedb6062.tar.gz
ports-51939c51c12e7a7bfed557c620068da8eedb6062.zip
Notes
Diffstat (limited to 'security/openvpn')
-rw-r--r--security/openvpn/Makefile31
-rw-r--r--security/openvpn/distinfo4
-rw-r--r--security/openvpn/files/patch-sample__sample-config-files__loopback-client13
-rw-r--r--security/openvpn/files/patch-sample__sample-config-files__loopback-server13
-rw-r--r--security/openvpn/files/patch-selftest-ports26
-rw-r--r--security/openvpn/files/patch-src__openvpn__syshead.h16
-rw-r--r--security/openvpn/files/patch-t_cltsrv.sh21
-rw-r--r--security/openvpn/pkg-plist110
8 files changed, 91 insertions, 143 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 516ccf0e902a..dfcf0d0f2fff 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openvpn
-DISTVERSION= 2.2.2
+DISTVERSION= 2.3.0
CATEGORIES= security net
# MASTER_SITES points to hosts in distinct data centers,
# so just one MASTER_SITES entry should be OK.
@@ -14,15 +14,17 @@ COMMENT= Secure IP/Ethernet tunnel daemon
LICENSE= GPLv2
-CONFLICTS_INSTALL= openvpn-devel-[0-9]* openvpn-2.0* openvpn-beta-[0-9]*
+CONFLICTS_INSTALL= openvpn-2.[!3].* openvpn-[!2].* openvpn-beta-[0-9]* openvpn-devel-[0-9]*
GNU_CONFIGURE= yes
USE_OPENSSL= yes
USE_XZ= yes
-CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
- --with-lzo-headers=${LOCALBASE}/include
+# let OpenVPN's configure script pick up the libraries
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= PW_SAVE PKCS11
+# PolarSSL missing: OpenVPN does not currently compile with PolarSSL 1.2.0+
+OPTIONS_DEFINE= PW_SAVE PKCS11
PW_SAVE_DESC= Interactive passwords may be read from a file
PKCS11_DESC= Use security/pkcs11-helper
@@ -63,14 +65,6 @@ LIB_DEPENDS+= pkcs11-helper:${PORTSDIR}/security/pkcs11-helper
CONFIGURE_ARGS+= --disable-pkcs11
.endif
-post-patch:
- @${FIND} ${WRKSRC}/easy-rsa/?.0 -type f \
- -exec ${REINPLACE_CMD} -e 's;#!/bin/bash;#!/bin/sh;' \
- -e 's,source ./vars,. ./vars,' \{\} +
- @${FIND} ${WRKSRC}/plugin -name Makefile \
- -exec ${REINPLACE_CMD} -e 's;gcc;${CC};g' '{}' +
- @${FIND} ${WRKSRC} \( -name \*.orig -o -name \*.bak \) -delete
-
pre-configure:
.ifdef (LOG_OPENVPN)
@${ECHO} "Building with LOG_OPENVPN=${LOG_OPENVPN}"
@@ -84,8 +78,6 @@ pre-configure:
.endif
post-build:
- cd ${WRKSRC}/plugin/down-root && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS}
- cd ${WRKSRC}/plugin/auth-pam && ${CC} ${CPPFLAGS} -I../.. -DDLOPEN_PAM=0 ${CFLAGS} -fPIC -shared -Wl,-soname,openvpn-auth-pam.so -o openvpn-auth-pam.so auth-pam.c pamdl.c -lc -lpam
@# self-tests here
.if !defined(WITHOUT_CHECK)
@${ECHO} ; ${ECHO} "### Note that you can skip these lengthy selftests with WITHOUT_CHECK=yes ###" ; ${ECHO}
@@ -94,21 +86,18 @@ post-build:
post-install:
${MKDIR} ${PREFIX}/lib
- ${INSTALL_PROGRAM} ${WRKSRC}/plugin/down-root/openvpn-down-root.so ${PREFIX}/lib/
- ${INSTALL_PROGRAM} ${WRKSRC}/plugin/auth-pam/openvpn-auth-pam.so ${PREFIX}/lib/
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/plugin/down-root/README ${DOCSDIR}/README.openvpn-down-root
- ${INSTALL_DATA} ${WRKSRC}/plugin/auth-pam/README ${DOCSDIR}/README.openvpn-auth-pam
.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL \
PORTS README
${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}/
.endfor
-.for dir in easy-rsa easy-rsa/1.0 easy-rsa/2.0 sample-config-files
+.for dir in sample/sample-config-files
+ ${RM} -f ${WRKSRC}/${dir}/*.orig
${MKDIR} ${DOCSDIR}/${dir}
${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f -exec ${INSTALL_DATA} \{\} ${DOCSDIR}/${dir} \;
.endfor
-.for dir in sample-scripts
+.for dir in sample/sample-scripts
${MKDIR} ${DOCSDIR}/${dir}
${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f -exec ${INSTALL_SCRIPT} \{\} ${DOCSDIR}/${dir} \;
.endfor
diff --git a/security/openvpn/distinfo b/security/openvpn/distinfo
index a9bca63e4151..0a0ff0d9b6fe 100644
--- a/security/openvpn/distinfo
+++ b/security/openvpn/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openvpn-2.2.2.tar.xz) = a694b9f661a0db30c048c94a4b4fc63d1460aea4dbc504a4f233f3c15997f4cd
-SIZE (openvpn-2.2.2.tar.xz) = 649356
+SHA256 (openvpn-2.3.0.tar.xz) = a9fcf7bc1c1cd88cd8867ff567e8f8df5e695f0e983bd0aed3a3e1f6ae14d107
+SIZE (openvpn-2.3.0.tar.xz) = 762052
diff --git a/security/openvpn/files/patch-sample__sample-config-files__loopback-client b/security/openvpn/files/patch-sample__sample-config-files__loopback-client
new file mode 100644
index 000000000000..47cac942e0b9
--- /dev/null
+++ b/security/openvpn/files/patch-sample__sample-config-files__loopback-client
@@ -0,0 +1,13 @@
+--- ./sample/sample-config-files/loopback-client.orig 2012-09-10 17:01:08.000000000 +0200
++++ ./sample/sample-config-files/loopback-client 2013-01-11 21:30:07.000000000 +0100
+@@ -9,8 +9,8 @@
+ # ./openvpn --config sample-config-files/loopback-client (In one window)
+ # ./openvpn --config sample-config-files/loopback-server (Simultaneously in another window)
+
+-rport 16000
+-lport 16001
++rport 16100
++lport 16101
+ remote localhost
+ local localhost
+ dev null
diff --git a/security/openvpn/files/patch-sample__sample-config-files__loopback-server b/security/openvpn/files/patch-sample__sample-config-files__loopback-server
new file mode 100644
index 000000000000..cd55ac640678
--- /dev/null
+++ b/security/openvpn/files/patch-sample__sample-config-files__loopback-server
@@ -0,0 +1,13 @@
+--- ./sample/sample-config-files/loopback-server.orig 2012-09-10 17:01:08.000000000 +0200
++++ ./sample/sample-config-files/loopback-server 2013-01-11 21:30:07.000000000 +0100
+@@ -9,8 +9,8 @@
+ # ./openvpn --config sample-config-files/loopback-client (In one window)
+ # ./openvpn --config sample-config-files/loopback-server (Simultaneously in another window)
+
+-rport 16001
+-lport 16000
++rport 16101
++lport 16100
+ remote localhost
+ local localhost
+ dev null
diff --git a/security/openvpn/files/patch-selftest-ports b/security/openvpn/files/patch-selftest-ports
deleted file mode 100644
index 5e195261eecb..000000000000
--- a/security/openvpn/files/patch-selftest-ports
+++ /dev/null
@@ -1,26 +0,0 @@
---- sample-config-files/loopback-client.orig Mon Oct 16 00:30:20 2006
-+++ sample-config-files/loopback-client Wed Apr 4 00:51:31 2007
-@@ -9,8 +9,8 @@
- # ./openvpn --config sample-config-files/loopback-client (In one window)
- # ./openvpn --config sample-config-files/loopback-server (Simultaneously in another window)
-
--rport 16000
--lport 16001
-+rport 16100
-+lport 16101
- remote localhost
- local localhost
- dev null
---- sample-config-files/loopback-server.orig Mon Oct 16 00:30:20 2006
-+++ sample-config-files/loopback-server Wed Apr 4 00:51:31 2007
-@@ -9,8 +9,8 @@
- # ./openvpn --config sample-config-files/loopback-client (In one window)
- # ./openvpn --config sample-config-files/loopback-server (Simultaneously in another window)
-
--rport 16001
--lport 16000
-+rport 16101
-+lport 16100
- remote localhost
- local localhost
- dev null
diff --git a/security/openvpn/files/patch-src__openvpn__syshead.h b/security/openvpn/files/patch-src__openvpn__syshead.h
new file mode 100644
index 000000000000..a30a7c95765f
--- /dev/null
+++ b/security/openvpn/files/patch-src__openvpn__syshead.h
@@ -0,0 +1,16 @@
+Work around "missing" TCP_NODELAY,
+obtained from: http://community.openvpn.net/openvpn/ticket/158
+
+--- ./src/openvpn/syshead.h.orig 2012-11-22 13:07:51.000000000 +0100
++++ ./src/openvpn/syshead.h 2013-01-11 21:30:07.000000000 +0100
+@@ -307,6 +307,10 @@
+ #include <netinet/ip.h>
+ #endif
+
++#ifdef HAVE_NETINET_TCP_H
++#include <netinet/tcp.h>
++#endif
++
+ #ifdef HAVE_NET_IF_TUN_H
+ #include <net/if_tun.h>
+ #endif
diff --git a/security/openvpn/files/patch-t_cltsrv.sh b/security/openvpn/files/patch-t_cltsrv.sh
deleted file mode 100644
index fbb05b3bd162..000000000000
--- a/security/openvpn/files/patch-t_cltsrv.sh
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./t_cltsrv.sh.orig 2011-05-16 14:21:55.000000000 +0200
-+++ ./t_cltsrv.sh 2011-08-17 00:25:49.000000000 +0200
-@@ -26,14 +26,14 @@
- FreeBSD)
- # FreeBSD jails map the outgoing IP to the jail IP - we need to
- # allow the real IP unless we want the test to run forever.
-- if test "`sysctl 2>/dev/null -n security.jail.jailed`" = 1 \
-- || ps -ostate= -p $$ | grep -q J; then
-+ if true ; then
- addopts="--float"
- if test "x`ifconfig | grep inet`" = x ; then
- echo "###"
-- echo "### To run the test in a FreeBSD jail, you MUST add an IP alias for the jail's IP."
-+ echo "### To run this test, it needs an inet/IP address. Skipping."
- echo "###"
-- exit 1
-+ trap 0
-+ exit 77
- fi
- fi
- ;;
diff --git a/security/openvpn/pkg-plist b/security/openvpn/pkg-plist
index 7200816ad93e..1e13653e3e26 100644
--- a/security/openvpn/pkg-plist
+++ b/security/openvpn/pkg-plist
@@ -1,81 +1,45 @@
+include/openvpn-plugin.h
+lib/openvpn/plugins/openvpn-plugin-auth-pam.la
+lib/openvpn/plugins/openvpn-plugin-auth-pam.so
+lib/openvpn/plugins/openvpn-plugin-down-root.la
+lib/openvpn/plugins/openvpn-plugin-down-root.so
sbin/openvpn
-lib/openvpn-auth-pam.so
-lib/openvpn-down-root.so
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT.GPL
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/management-notes.txt
%%PORTDOCS%%%%DOCSDIR%%/PORTS
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.openvpn-auth-pam
-%%PORTDOCS%%%%DOCSDIR%%/README.openvpn-down-root
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/README
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-ca
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-dh
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-key
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-key-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-key-pkcs12
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-key-server
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-req-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/clean-all
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/list-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/make-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/openssl.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/revoke-crt
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/revoke-full
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/sign-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/vars
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/Makefile
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/README
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-ca
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-dh
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-pkcs12
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-server
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-req-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/clean-all
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/inherit-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/list-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/openssl-0.9.6.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/openssl-0.9.8.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/openssl-1.0.0.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/pkitool
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/revoke-full
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/sign-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/vars
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/whichopensslcnf
-%%PORTDOCS%%%%DOCSDIR%%/management-notes.txt
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/README
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/client.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/firewall.sh
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/home.up
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/loopback-client
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/loopback-server
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/office.up
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/openvpn-shutdown.sh
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/openvpn-startup.sh
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/server.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/static-home.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/static-office.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/tls-home.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/tls-office.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/xinetd-client-config
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/xinetd-server-config
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/auth-pam.pl
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/bridge-start
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/bridge-stop
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/openvpn.init
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/ucn.pl
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/verify-cn
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample-scripts
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample-config-files
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/easy-rsa/2.0
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/easy-rsa/1.0
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/easy-rsa
+%%PORTDOCS%%%%DOCSDIR%%/README.auth-pam
+%%PORTDOCS%%%%DOCSDIR%%/README.down-root
+%%PORTDOCS%%%%DOCSDIR%%/README.IPv6
+%%PORTDOCS%%%%DOCSDIR%%/README.polarssl
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/README
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/client.conf
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/firewall.sh
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/home.up
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/loopback-client
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/loopback-server
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/office.up
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/openvpn-shutdown.sh
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/openvpn-startup.sh
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/server.conf
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/static-home.conf
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/static-office.conf
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/tls-home.conf
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/tls-office.conf
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/xinetd-client-config
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-config-files/xinetd-server-config
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-scripts/auth-pam.pl
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-scripts/bridge-start
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-scripts/bridge-stop
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-scripts/ucn.pl
+%%PORTDOCS%%%%DOCSDIR%%/sample/sample-scripts/verify-cn
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample/sample-scripts
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample/sample-config-files
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/openvpn/plugins
+@dirrm lib/openvpn