aboutsummaryrefslogtreecommitdiff
path: root/security/ophcrack
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-06-22 09:03:13 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-06-22 09:03:13 +0000
commit7ee87463a6ecd4617d6b35e5afb45693c7620633 (patch)
treeb5cb01f1f28a7c2fbf9e127e3e7ec7934d97a25a /security/ophcrack
parent41a0fe9cf195b1bcdcc9cf1f1f44d090dda50d3b (diff)
downloadports-7ee87463a6ecd4617d6b35e5afb45693c7620633.tar.gz
ports-7ee87463a6ecd4617d6b35e5afb45693c7620633.zip
Notes
Diffstat (limited to 'security/ophcrack')
-rw-r--r--security/ophcrack/Makefile76
-rw-r--r--security/ophcrack/distinfo12
-rw-r--r--security/ophcrack/files/patch-src_misc.c10
-rw-r--r--security/ophcrack/files/pkg-message.in10
-rw-r--r--security/ophcrack/pkg-plist8
5 files changed, 40 insertions, 76 deletions
diff --git a/security/ophcrack/Makefile b/security/ophcrack/Makefile
index 3be57884b1e6..fcc08daef47a 100644
--- a/security/ophcrack/Makefile
+++ b/security/ophcrack/Makefile
@@ -6,71 +6,49 @@
#
PORTNAME= ophcrack
-PORTVERSION= 2.4.1
-PORTREVISION= 4
+PORTVERSION= 3.3.1
CATEGORIES= security
MASTER_SITES= SF
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} bkhive-${TOOLS_VER}${EXTRACT_SUFX} \
- samdump2-${TOOLS_VER}${EXTRACT_SUFX}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Windows password cracker based on rainbow tables
-USE_GNOME= gtk20
-USE_OPENSSL= yes
+USE_BZIP2= yes
GNU_CONFIGURE= yes
-SUB_FILES+= pkg-message
+USE_GMAKE= yes
+USE_OPENSSL= yes
+
+PLIST_FILES= bin/ophcrack
PORTDOCS= *
-MAN1= bkhive.1 samdump2.1
-TOOLS_VER= 1.1.1
+OPTIONS= GUI "Build GUI frontend (Qt4)" on \
+ GRAPH "Enable graph rendering with Qwt" off \
+ DEBUG "Make debug build" off
+
+.include <bsd.port.options.mk>
-post-patch:
- @${REINPLACE_CMD} -e '/^CFLAGS=/d' ${WRKSRC}/${CONFIGURE_SCRIPT}
-# Do not install any Linux binaries: we build and install native ones;
-# mute their banner as well in favor of our nice pkg-message
- @${REINPLACE_CMD} -e 's/ install-exec-local// ; 605,617d' \
- ${WRKSRC}/Makefile.in
-# Hint the tools about correct endianness
- @${REINPLACE_CMD} -e '22s,^$$,#include <sys/endian.h>,' \
- ${WRKDIR}/bkhive-${TOOLS_VER}/bkhive.c
- @${REINPLACE_CMD} -e '26s,^$$,#include <sys/endian.h>,' \
- ${WRKDIR}/bkhive-${TOOLS_VER}/hive.c
- @${REINPLACE_CMD} -e '27s,^$$,#include <sys/endian.h>,' \
- ${WRKDIR}/samdump2-${TOOLS_VER}/samdump2.c
-# FreeBSD does not have <byteswap.h>
- @${REINPLACE_CMD} -e '/byteswap\.h/d' \
- ${WRKDIR}/bkhive-${TOOLS_VER}/bkhive.c \
- ${WRKDIR}/bkhive-${TOOLS_VER}/hive.c \
- ${WRKDIR}/samdump2-${TOOLS_VER}/samdump2.c
-# And our swap function names are prettier
- @${REINPLACE_CMD} -E 's,__bswap_([[:digit:]]+),bswap\1,' \
- ${WRKDIR}/bkhive-${TOOLS_VER}/hive.c \
- ${WRKDIR}/samdump2-${TOOLS_VER}/samdump2.c
-# Link to file instead of patching identical copy
- @${LN} -sf ../bkhive-${TOOLS_VER}/hive.c \
- ${WRKDIR}/samdump2-${TOOLS_VER}/hive.c
+.if defined(WITH_GUI) || defined(WITH_GRAPH)
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build uic_build corelib gui
+.else
+CONFIGURE_ARGS+= --disable-gui
+.endif
+
+# Enable with care, will pull Qt Designer by default, which is pretty heavy
+.if defined(WITH_GRAPH)
+LIB_DEPENDS= qwt.5:${PORTSDIR}/x11-toolkits/qwt5
+.else
+CONFIGURE_ARGS+= --disable-graph
+.endif
-post-build:
-# Build auxiliary tools (useful: e.g., samdump2 is called at runtime)
- (cd ${WRKDIR}/bkhive-${TOOLS_VER} && ${CC} ${CFLAGS} -o bkhive \
- hive.c bkhive.c)
- (cd ${WRKDIR}/samdump2-${TOOLS_VER} && ${CC} ${CFLAGS} -o samdump2 \
- hive.c samdump2.c -lssl)
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
post-install:
-# Install auxiliary tools and their manpages
- ${INSTALL_PROGRAM} ${WRKDIR}/bkhive-${TOOLS_VER}/bkhive \
- ${WRKDIR}/samdump2-${TOOLS_VER}/samdump2 ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKDIR}/bkhive-${TOOLS_VER}/bkhive.1 \
- ${WRKDIR}/samdump2-${TOOLS_VER}/samdump2.1 \
- ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README ${DOCSDIR}
.endif
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
.include <bsd.port.mk>
diff --git a/security/ophcrack/distinfo b/security/ophcrack/distinfo
index 6deb5659621b..ef97bc70cd16 100644
--- a/security/ophcrack/distinfo
+++ b/security/ophcrack/distinfo
@@ -1,9 +1,3 @@
-MD5 (ophcrack-2.4.1.tar.gz) = 9087eb77378bfcf02a843550cd6fc2ec
-SHA256 (ophcrack-2.4.1.tar.gz) = bb7723e2a3a289a16b7c76f1a6ba4b38007a41e675a437b6ae3e115613f7f355
-SIZE (ophcrack-2.4.1.tar.gz) = 171256
-MD5 (bkhive-1.1.1.tar.gz) = bb5e076f3051c60331a7831b6c11719d
-SHA256 (bkhive-1.1.1.tar.gz) = 3f5f85b507d56c09944b394c94551fa27d6fc5ca21ec033e4ebd98ac47417e68
-SIZE (bkhive-1.1.1.tar.gz) = 15985
-MD5 (samdump2-1.1.1.tar.gz) = f8c321594444df2dd3ca5be040ca5097
-SHA256 (samdump2-1.1.1.tar.gz) = 51310babf8f23933a03aba115ae7ac7282d4f16cd6aa96fe3650ff294fb3516e
-SIZE (samdump2-1.1.1.tar.gz) = 18888
+MD5 (ophcrack-3.3.1.tar.bz2) = 740eef54e9082f26851e15c1cb4ef55c
+SHA256 (ophcrack-3.3.1.tar.bz2) = 4e23bfccde7962a873cd0c44f4da626795aec17fcfb078f4329ec7145b218d18
+SIZE (ophcrack-3.3.1.tar.bz2) = 255238
diff --git a/security/ophcrack/files/patch-src_misc.c b/security/ophcrack/files/patch-src_misc.c
new file mode 100644
index 000000000000..80a752366a0e
--- /dev/null
+++ b/security/ophcrack/files/patch-src_misc.c
@@ -0,0 +1,10 @@
+--- src/misc.c.orig 2009-07-29 13:50:26.000000000 +0800
++++ src/misc.c 2010-06-22 11:18:50.000000000 +0800
+@@ -31,6 +31,7 @@
+ *
+ *
+ */
++#include <sys/types.h>
+ #include <config.h>
+ #include <string.h>
+ #include <stdio.h>
diff --git a/security/ophcrack/files/pkg-message.in b/security/ophcrack/files/pkg-message.in
deleted file mode 100644
index 54e46fbaab67..000000000000
--- a/security/ophcrack/files/pkg-message.in
+++ /dev/null
@@ -1,10 +0,0 @@
-Don't forget to download the tables from
-
- http://lasecwww.epfl.ch/SSTIC04-10k.zip, or
- http://lasecwww.epfl.ch/SSTIC04-5k.zip
-
-and install them in %%DATADIR%%/10000 or
-%%DATADIR%%/5000, respectively.
-
-SSTIC04-10k (388MB), for PCs with at least 256MB of RAM.
-SSTIC04-5k (720MB), for PCs with at least 512MB of RAM.
diff --git a/security/ophcrack/pkg-plist b/security/ophcrack/pkg-plist
deleted file mode 100644
index 33e28ee8dbb2..000000000000
--- a/security/ophcrack/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/bkhive
-bin/ophcrack
-bin/samdump2
-%%DATADIR%%/pixmaps/logo_os.xpm
-%%DATADIR%%/pixmaps/os.ico
-%%DATADIR%%/pixmaps/os.xpm
-@dirrm %%DATADIR%%/pixmaps
-@dirrm %%DATADIR%%