aboutsummaryrefslogtreecommitdiff
path: root/security/ophcrack
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-03-10 11:40:33 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-03-10 11:40:33 +0000
commit00cf29527cd22dbf4d0c0b0e4cf2da337210d280 (patch)
treed8e4e3562bc7d4038de89e4bf2f782d059c46372 /security/ophcrack
parent0de8cda459ea701043e256f41db8939c0450b2cf (diff)
downloadports-00cf29527cd22dbf4d0c0b0e4cf2da337210d280.tar.gz
ports-00cf29527cd22dbf4d0c0b0e4cf2da337210d280.zip
Notes
Diffstat (limited to 'security/ophcrack')
-rw-r--r--security/ophcrack/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/security/ophcrack/Makefile b/security/ophcrack/Makefile
index 33d944726852..346b6cde2c3b 100644
--- a/security/ophcrack/Makefile
+++ b/security/ophcrack/Makefile
@@ -45,12 +45,17 @@ LIB_DEPENDS+= qwt:${PORTSDIR}/x11-toolkits/qwt5
CONFIGURE_ARGS+= --disable-graph
.endif
+post-patch:
+ @${REINPLACE_CMD} -E '/#include <byteswap\.h>/d ; \
+ /#include/s,"bswap\.h",<machine/endian.h>, ; \
+ s,bswap_([[:digit:]]+),bswap\1, ' \
+ ${WRKSRC}/src/samdump2/bkhive.c \
+ ${WRKSRC}/src/samdump2/hive.c \
+ ${WRKSRC}/src/samdump2/samdump2.c \
+ ${WRKSRC}/src/misc.h
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
.include <bsd.port.mk>