aboutsummaryrefslogtreecommitdiff
path: root/security/ossec-hids-server
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-12-30 10:53:43 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-12-30 10:53:43 +0000
commit434a5ea1da43a08e20072b292d304ce175a45d60 (patch)
treeb0c6095b451fba812dfa09464282384ab73e1470 /security/ossec-hids-server
parent174625caccfac53ca3ad1d330be16d973ab345f2 (diff)
downloadports-434a5ea1da43a08e20072b292d304ce175a45d60.tar.gz
ports-434a5ea1da43a08e20072b292d304ce175a45d60.zip
Notes
Diffstat (limited to 'security/ossec-hids-server')
-rw-r--r--security/ossec-hids-server/Makefile24
-rw-r--r--security/ossec-hids-server/distinfo6
-rw-r--r--security/ossec-hids-server/files/pkg-message.in9
-rw-r--r--security/ossec-hids-server/pkg-plist8
4 files changed, 40 insertions, 7 deletions
diff --git a/security/ossec-hids-server/Makefile b/security/ossec-hids-server/Makefile
index 2a7019fd491e..8dfe96dfd453 100644
--- a/security/ossec-hids-server/Makefile
+++ b/security/ossec-hids-server/Makefile
@@ -6,18 +6,24 @@
#
PORTNAME= ossec-hids
-PORTVERSION= 1.3
+PORTVERSION= 1.4
PORTREVISION?= 0
CATEGORIES= security
MASTER_SITES= http://www.ossec.net/files/ \
http://www.ossec.net/files/old/
-PKGNAMESUFFIX?= -server
+PKGNAMESUFFIX= -server
MAINTAINER= valerio.daelli@gmail.com
-COMMENT= A security tool to monitor and check logs and intrusions
+COMMENT?= A security tool to monitor and check logs and intrusions
USE_RC_SUBR= ossec-hids
+.if defined(WITH_DB)
+USE_MYSQL= yes
+USE_PGSQL= yes
+USE_BDB= yes
+.endif
+
SUB_LIST= PORTNAME=${PORTNAME}
SUB_FILES= pkg-message
PLIST_SUB= PORTNAME=${PORTNAME}
@@ -40,7 +46,19 @@ post-patch:
@${REINPLACE_CMD} 's|PREFIX|${PREFIX}/${PORTNAME}|' ${WRKSRC}/src/headers/defs.h
do-build:
+.if defined(WITH_DB)
+.if defined(CLIENT_ONLY)
+ @cd ${WRKSRC}/src;${MAKE} setagent;${MAKE} all;${MAKE} build
+.else
+ @cd ${WRKSRC}/src;${MAKE} setdb;${MAKE} all;${MAKE} build
+.endif
+.else
+.if defined(CLIENT_ONLY)
+ @cd ${WRKSRC}/src;${MAKE} setagent;${MAKE} all;${MAKE} build
+.else
@cd ${WRKSRC}/src;${MAKE} all;${MAKE} build
+.endif
+.endif
.if defined(CLIENT_ONLY)
do-install:
diff --git a/security/ossec-hids-server/distinfo b/security/ossec-hids-server/distinfo
index 791ff159d416..213d8658f0a1 100644
--- a/security/ossec-hids-server/distinfo
+++ b/security/ossec-hids-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (ossec-hids-1.3.tar.gz) = 5ab287c009c48c72ffcbf1e2574e8bf6
-SHA256 (ossec-hids-1.3.tar.gz) = 71aab72703ce2513a7e9d1bfe89aa8b288cf43fdcc84d5cc3f2696c2981af14e
-SIZE (ossec-hids-1.3.tar.gz) = 553438
+MD5 (ossec-hids-1.4.tar.gz) = f877f7afc225ba835bf697c026c77aa9
+SHA256 (ossec-hids-1.4.tar.gz) = 0dd7650a4c74ae2b9beec47660fd7c573eb35005e5cab6e62c640ba44930ff7f
+SIZE (ossec-hids-1.4.tar.gz) = 598579
diff --git a/security/ossec-hids-server/files/pkg-message.in b/security/ossec-hids-server/files/pkg-message.in
index 438309da3e53..d4be60736e68 100644
--- a/security/ossec-hids-server/files/pkg-message.in
+++ b/security/ossec-hids-server/files/pkg-message.in
@@ -4,7 +4,14 @@ for your environment. All the files related to %%PORTNAME%% have been installed
For information on proper configuration, see http://www.ossec.net/.
-To enable the startup script, add ossec-hids_enable="YES" to /etc/rc.conf.
+To enable the startup script, add ossechids_enable="YES" to /etc/rc.conf.
+To enable database output, execute:
+
+%%PREFIX%%/%%PORTNAME%%/bin/ossec-control enable database
+
+Then check this tutorial:
+
+http://www.ossec.net/wiki/index.php/Know_How:DatabaseOutput
When you deinstall this port after starting the daemons once, many directories that are
created by the daemons will remain. To fully remove the port you need to delete those
diff --git a/security/ossec-hids-server/pkg-plist b/security/ossec-hids-server/pkg-plist
index 92c70af4d5bd..6b9397bfd7d9 100644
--- a/security/ossec-hids-server/pkg-plist
+++ b/security/ossec-hids-server/pkg-plist
@@ -1,12 +1,16 @@
%%PORTNAME%%/active-response/bin/disable-account.sh
%%PORTNAME%%/active-response/bin/firewall-drop.sh
%%PORTNAME%%/active-response/bin/host-deny.sh
+%%PORTNAME%%/active-response/bin/ipfw_mac.sh
+%%PORTNAME%%/active-response/bin/ipfw.sh
+%%PORTNAME%%/active-response/bin/pf.sh
%%PORTNAME%%/active-response/bin/route-null.sh
%%PORTNAME%%/bin/clear_stats
%%PORTNAME%%/bin/list_agents
%%PORTNAME%%/bin/manage_agents
%%PORTNAME%%/bin/ossec-agentd
%%PORTNAME%%/bin/ossec-analysisd
+%%PORTNAME%%/bin/ossec-dbd
%%PORTNAME%%/bin/ossec-control
%%PORTNAME%%/bin/ossec-execd
%%PORTNAME%%/bin/ossec-logcollector
@@ -21,6 +25,7 @@
%%PORTNAME%%/etc/ossec.conf.sample
%%PORTNAME%%/etc/shared/rootkit_files.txt
%%PORTNAME%%/etc/shared/rootkit_trojans.txt
+%%PORTNAME%%/etc/shared/system_audit_rcl.txt
%%PORTNAME%%/etc/shared/win_applications_rcl.txt
%%PORTNAME%%/etc/shared/win_audit_rcl.txt
%%PORTNAME%%/etc/shared/win_malware_rcl.txt
@@ -40,6 +45,7 @@
%%PORTNAME%%/rules/ms-exchange_rules.xml
%%PORTNAME%%/rules/ms_ftpd_rules.xml
%%PORTNAME%%/rules/msauth_rules.xml
+%%PORTNAME%%/rules/mysql_rules.xml
%%PORTNAME%%/rules/named_rules.xml
%%PORTNAME%%/rules/netscreenfw_rules.xml
%%PORTNAME%%/rules/ossec_rules.xml
@@ -47,12 +53,14 @@
%%PORTNAME%%/rules/pix_rules.xml
%%PORTNAME%%/rules/policy_rules.xml
%%PORTNAME%%/rules/postfix_rules.xml
+%%PORTNAME%%/rules/postgresql_rules.xml
%%PORTNAME%%/rules/proftpd_rules.xml
%%PORTNAME%%/rules/pure-ftpd_rules.xml
%%PORTNAME%%/rules/racoon_rules.xml
%%PORTNAME%%/rules/rules_config.xml
%%PORTNAME%%/rules/sendmail_rules.xml
%%PORTNAME%%/rules/smbd_rules.xml
+%%PORTNAME%%/rules/sonicwall_rules.xml
%%PORTNAME%%/rules/spamd_rules.xml
%%PORTNAME%%/rules/squid_rules.xml
%%PORTNAME%%/rules/sshd_rules.xml