aboutsummaryrefslogtreecommitdiff
path: root/security/osslsigncode
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2006-11-11 13:55:05 +0000
committerFrank J. Laszlo <laszlof@FreeBSD.org>2006-11-11 13:55:05 +0000
commit6ebfbc8583f1c9d069c63104e20be4ed6cf45fa8 (patch)
tree7f7338f7596657445dde8b467cf968f5abd49e1f /security/osslsigncode
parenta0b57d57f775458ded31b4d2266d9e6cf62865b1 (diff)
downloadports-6ebfbc8583f1c9d069c63104e20be4ed6cf45fa8.tar.gz
ports-6ebfbc8583f1c9d069c63104e20be4ed6cf45fa8.zip
Notes
Diffstat (limited to 'security/osslsigncode')
-rw-r--r--security/osslsigncode/Makefile30
-rw-r--r--security/osslsigncode/distinfo3
-rw-r--r--security/osslsigncode/files/patch-osslsigncode.c15
-rw-r--r--security/osslsigncode/pkg-descr4
4 files changed, 52 insertions, 0 deletions
diff --git a/security/osslsigncode/Makefile b/security/osslsigncode/Makefile
new file mode 100644
index 000000000000..bb541aee61bb
--- /dev/null
+++ b/security/osslsigncode/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: osslsigncode
+# Date created: 9 November 2006
+# Whom: snb@threerings.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= osslsigncode
+PORTVERSION= 1.2
+CATEGORIES= security devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= snb@threerings.net
+COMMENT= OpenSSL-based signcode utility
+
+PLIST_FILES= bin/osslsigncode
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_OPENSSL= yes
+
+.if !defined(WITHOUT_CURL)
+LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/osslsigncode/distinfo b/security/osslsigncode/distinfo
new file mode 100644
index 000000000000..8f33d7d3486c
--- /dev/null
+++ b/security/osslsigncode/distinfo
@@ -0,0 +1,3 @@
+MD5 (osslsigncode-1.2.tar.gz) = e97a583463feddcce524cc4067a57e04
+SHA256 (osslsigncode-1.2.tar.gz) = 5cd55fa974b06bf89ee128137a969e58a8c6ea1df20b100ddb6b23a58682bec8
+SIZE (osslsigncode-1.2.tar.gz) = 83752
diff --git a/security/osslsigncode/files/patch-osslsigncode.c b/security/osslsigncode/files/patch-osslsigncode.c
new file mode 100644
index 000000000000..8d2a1c6d27ab
--- /dev/null
+++ b/security/osslsigncode/files/patch-osslsigncode.c
@@ -0,0 +1,15 @@
+--- osslsigncode.c.orig Fri Jan 21 04:23:44 2005
++++ osslsigncode.c Thu Nov 9 15:31:37 2006
+@@ -610,9 +610,10 @@
+
+ BIO_write(hash, indata + i, st.st_size - i);
+
+- /* pad (with 0's) pe file to 8 byte boundary */
++ /* pad (with 0's) pe file to 8 byte boundary, but do not pad at all if
++ already aligned on 8 byte boundary. See http://sourceforge.net/tracker/index.php?func=detail&aid=1422627&group_id=129143&atid=713906 */
+ len = 8 - st.st_size % 8;
+- if (len > 0) {
++ if (len > 0 && len != 8) {
+ memset(buf, 0, len);
+ BIO_write(hash, buf, len);
+ st.st_size += len;
diff --git a/security/osslsigncode/pkg-descr b/security/osslsigncode/pkg-descr
new file mode 100644
index 000000000000..4f8155362580
--- /dev/null
+++ b/security/osslsigncode/pkg-descr
@@ -0,0 +1,4 @@
+Platform-independent tool for Authenticode signing of EXE/CAB files - uses
+OpenSSL and libcurl. It also supports timestamping.
+
+WWW: http://sourceforge.net/projects/osslsigncode/