aboutsummaryrefslogtreecommitdiff
path: root/security/p11-kit
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2011-09-16 02:27:45 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2011-09-16 02:27:45 +0000
commitbe26d6d8b6b85e07094ed39fcf98827bc9210114 (patch)
tree94033e63f99c1bec0c8ca6fe8669622c19dbfa3a /security/p11-kit
parent0932da9d0199e4527c4e7efc9d05a309f81a5388 (diff)
downloadports-be26d6d8b6b85e07094ed39fcf98827bc9210114.tar.gz
ports-be26d6d8b6b85e07094ed39fcf98827bc9210114.zip
Notes
Diffstat (limited to 'security/p11-kit')
-rw-r--r--security/p11-kit/Makefile4
-rw-r--r--security/p11-kit/distinfo4
-rw-r--r--security/p11-kit/files/patch-p11-kit-modules.c16
3 files changed, 20 insertions, 4 deletions
diff --git a/security/p11-kit/Makefile b/security/p11-kit/Makefile
index c9fe7e101bbb..0459c9e0379a 100644
--- a/security/p11-kit/Makefile
+++ b/security/p11-kit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= p11-kit
-PORTVERSION= 0.5
+PORTVERSION= 0.6
CATEGORIES= security devel
MASTER_SITES= http://p11-glue.freedesktop.org/releases/
@@ -23,7 +23,7 @@ USE_LDCONFIG= yes
pre-configure:
@${REINPLACE_CMD} -e \
- 's|exampledir = $$(p11_system_dir)|exampledir = ${EXAMPLESDIR}|' \
+ 's|exampledir = $$(p11_system_config)|exampledir = ${EXAMPLESDIR}|' \
${WRKSRC}/${PORTNAME}/Makefile.in
.include <bsd.port.mk>
diff --git a/security/p11-kit/distinfo b/security/p11-kit/distinfo
index 19d9a6f5a6ec..10e09ac72b31 100644
--- a/security/p11-kit/distinfo
+++ b/security/p11-kit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (p11-kit-0.5.tar.gz) = fa949dd3fc99d84a5bdb00527ecdfa039c788dfef793cb9f23b7e52d2b23bd94
-SIZE (p11-kit-0.5.tar.gz) = 517604
+SHA256 (p11-kit-0.6.tar.gz) = ac0f55ff8d4df2b791260ae00b0e33ed20b46caaebe1a411426643d1417188bc
+SIZE (p11-kit-0.6.tar.gz) = 519899
diff --git a/security/p11-kit/files/patch-p11-kit-modules.c b/security/p11-kit/files/patch-p11-kit-modules.c
new file mode 100644
index 000000000000..1b02a4221e8a
--- /dev/null
+++ b/security/p11-kit/files/patch-p11-kit-modules.c
@@ -0,0 +1,16 @@
+--- p11-kit/modules.c.orig 2011-09-15 18:15:24.000000000 -0700
++++ p11-kit/modules.c 2011-09-15 18:16:27.000000000 -0700
+@@ -50,11 +50,12 @@
+ #include <dirent.h>
+ #include <dlfcn.h>
+ #include <errno.h>
++#include <limits.h>
+ #include <pthread.h>
+ #include <stdarg.h>
+ #include <stddef.h>
+-#include <stdlib.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
+