aboutsummaryrefslogtreecommitdiff
path: root/security/p5-App-Acmeman/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-12-23 13:16:23 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-12-23 13:16:23 +0000
commit474075d56d10df4ae3a99160af9e0d1584d856d7 (patch)
tree34b96a26db458c6c1fc44dddfaf9b625dca69e88 /security/p5-App-Acmeman/Makefile
parent6938310ec8803fd1243a6d777dde7d6481348352 (diff)
downloadports-474075d56d10df4ae3a99160af9e0d1584d856d7.tar.gz
ports-474075d56d10df4ae3a99160af9e0d1584d856d7.zip
Notes
Diffstat (limited to 'security/p5-App-Acmeman/Makefile')
-rw-r--r--security/p5-App-Acmeman/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/security/p5-App-Acmeman/Makefile b/security/p5-App-Acmeman/Makefile
new file mode 100644
index 000000000000..bee79b0c2bf5
--- /dev/null
+++ b/security/p5-App-Acmeman/Makefile
@@ -0,0 +1,40 @@
+# Created by: Zeus Panchenko <zeus@gnu.org.ua>
+# $FreeBSD$
+
+PORTNAME= App-Acmeman
+PORTVERSION= 3.02
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Automatic management of ACME (Let's Encrypt) SSL certificates
+
+LICENSE= GPLv3+
+
+RUN_DEPENDS= p5-Apache-Config-Preproc>=1.03:www/p5-Apache-Config-Preproc \
+ p5-Apache-Defaults>=1.02:www/p5-Apache-Defaults \
+ p5-Config-Parser>=1.03:devel/p5-Config-Parser \
+ p5-Crypt-OpenSSL-PKCS10>=0.16:security/p5-Crypt-OpenSSL-PKCS10 \
+ p5-Crypt-OpenSSL-X509>=1.804:security/p5-Crypt-OpenSSL-X509 \
+ p5-DateTime-Format-Strptime>=1.42:devel/p5-DateTime-Format-Strptime \
+ p5-LWP-Protocol-https>=6.04:www/p5-LWP-Protocol-https \
+ p5-Net-ACME2>=0.33:net/p5-Net-ACME2 \
+ p5-libwww>=6.05:www/p5-libwww
+
+NO_ARCH= yes
+USES= perl5
+USE_PERL5= configure
+
+post-extract:
+ @${CP} ${FILESDIR}/Unconfigured.pm ${WRKSRC}/lib/App/Acmeman/Source
+
+post-patch:
+ @${REINPLACE_CMD} -e '/config_file =/s,/etc,${PREFIX}&,' \
+ ${WRKSRC}/lib/App/Acmeman.pm
+
+post-stage:
+ @${PRINTF} "[core]\n\tsource = unconfigured\n" > \
+ ${STAGEDIR}${PREFIX}/etc/acmeman.conf.sample
+
+.include <bsd.port.mk>