aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Bitcard/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-01-16 13:09:32 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-01-16 13:09:32 +0000
commitaf1d88f66a0cc8a4f3616d09c86652871fc2aa1b (patch)
tree05ffa423d18aec70d4516b1968b0be56c91644d0 /security/p5-Authen-Bitcard/Makefile
parentd9da78a0ff14ac0248ec3a6c091fc01aa4f7b09b (diff)
downloadports-af1d88f66a0cc8a4f3616d09c86652871fc2aa1b.tar.gz
ports-af1d88f66a0cc8a4f3616d09c86652871fc2aa1b.zip
Notes
Diffstat (limited to 'security/p5-Authen-Bitcard/Makefile')
-rw-r--r--security/p5-Authen-Bitcard/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/p5-Authen-Bitcard/Makefile b/security/p5-Authen-Bitcard/Makefile
new file mode 100644
index 000000000000..fe71000b3f92
--- /dev/null
+++ b/security/p5-Authen-Bitcard/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Authen-Bitcard
+# Date created: 2007/01/16
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Bitcard
+PORTVERSION= 0.86
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Bitcard authentication verification
+
+BUILD_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::Bitcard.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>