aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-NTLM/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-08 09:44:48 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-08 09:44:48 +0000
commit9bf2eb4547725394e754cd561055f569cb97796a (patch)
treee6fa1c6ffc3cfd4ac7a69f059f37d95d220fba1e /security/p5-Authen-NTLM/Makefile
parent7756498995f05c15bd7e02274246ccab89240aa6 (diff)
The NTLM (Windows NT LAN Manager) authentication scheme is the
authentication algorithm used by Microsoft. NTLM authentication scheme is used in DCOM and HTTP environment. It is used to authenticate DCE RPC packets in DCOM. It is also used to authenticate HTTP packets to MS Web Proxy or MS Web Server. Currently, it is the authentication scheme Internet Explorer chooses to authenticate itself to proxies/web servers that supports NTLM. WWW: http://search.cpan.org/dist/Authen-NTLM/ PR: ports/98684 Submitted by: James Thomason <james@divide.org>
Notes
Notes: svn path=/head/; revision=164802
Diffstat (limited to 'security/p5-Authen-NTLM/Makefile')
-rw-r--r--security/p5-Authen-NTLM/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/p5-Authen-NTLM/Makefile b/security/p5-Authen-NTLM/Makefile
new file mode 100644
index 000000000000..d005568486bc
--- /dev/null
+++ b/security/p5-Authen-NTLM/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Authen-NTLM
+# Date created: June 07 2006
+# Whom: James Thomason <james@divide.org>
+#
+#
+# $FreeBSD$
+
+PORTNAME= NTLM
+PORTVERSION= 1.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= james@divide.org
+COMMENT= Perl extension to authenticate against an NTLM server
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::NTLM.3
+
+.include <bsd.port.mk>