aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-OATH
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-01-12 13:16:53 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-01-12 13:16:53 +0000
commitdf83b37884d8a235d51a7b7bf268f784c0e20aca (patch)
tree02a9c5ce095ef7cdbebc9aee1f090e18389b4514 /security/p5-Authen-OATH
parentd9939c32b9a45090d380344539ae5d09a0acd346 (diff)
downloadports-df83b37884d8a235d51a7b7bf268f784c0e20aca.tar.gz
ports-df83b37884d8a235d51a7b7bf268f784c0e20aca.zip
The Authen::OATH module provides a Perl implementation of the
HOTP and TOTP One Time Password algorithms as defined by OATH (http://www.openautentication.org). WWW: http://search.cpan.org/dist/Authen-OATH/ PR: ports/164035 (based on) Submitted by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=289020
Diffstat (limited to 'security/p5-Authen-OATH')
-rw-r--r--security/p5-Authen-OATH/Makefile30
-rw-r--r--security/p5-Authen-OATH/distinfo2
-rw-r--r--security/p5-Authen-OATH/pkg-descr5
-rw-r--r--security/p5-Authen-OATH/pkg-plist5
4 files changed, 42 insertions, 0 deletions
diff --git a/security/p5-Authen-OATH/Makefile b/security/p5-Authen-OATH/Makefile
new file mode 100644
index 000000000000..ab418d78630a
--- /dev/null
+++ b/security/p5-Authen-OATH/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Authen-OATH
+# Date created: 2012-01-12
+# Whom: Jui-Nan Lin <jnlin@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-OATH
+PORTVERSION= 1.0.0
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= jnlin@csie.nctu.edu.tw
+COMMENT= OATH one time passwords implementation
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Digest-HMAC>0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-Digest-SHA1>0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Moose>0:${PORTSDIR}/devel/p5-Moose
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::OATH.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Authen-OATH/distinfo b/security/p5-Authen-OATH/distinfo
new file mode 100644
index 000000000000..0ddb72056d5f
--- /dev/null
+++ b/security/p5-Authen-OATH/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Authen-OATH-v1.0.0.tar.gz) = 360e660d1cc9f396ae679c2d239226ce4f8e57e7cdcc54b420bbf373c20e3d0a
+SIZE (Authen-OATH-v1.0.0.tar.gz) = 5142
diff --git a/security/p5-Authen-OATH/pkg-descr b/security/p5-Authen-OATH/pkg-descr
new file mode 100644
index 000000000000..b04679836570
--- /dev/null
+++ b/security/p5-Authen-OATH/pkg-descr
@@ -0,0 +1,5 @@
+The Authen::OATH module provides a Perl implementation of the
+HOTP and TOTP One Time Password algorithms as defined by OATH
+(http://www.openautentication.org).
+
+WWW: http://search.cpan.org/dist/Authen-OATH/
diff --git a/security/p5-Authen-OATH/pkg-plist b/security/p5-Authen-OATH/pkg-plist
new file mode 100644
index 000000000000..4c3927f7c8c1
--- /dev/null
+++ b/security/p5-Authen-OATH/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Authen/OATH.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/OATH/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/OATH
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen
+@dirrmtry %%SITE_PERL%%/Authen