aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-PAAS/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-23 05:00:05 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-23 05:00:05 +0000
commit2b2737e54baa0d12baaac872267c3a46f08cc13f (patch)
tree98ac4e5dc19049fc9e217a0c1a5cc0685659784b /security/p5-Authen-PAAS/Makefile
parente600a0d64f6808d051512974693093f3bf7996f9 (diff)
downloadports-2b2737e54baa0d12baaac872267c3a46f08cc13f.tar.gz
ports-2b2737e54baa0d12baaac872267c3a46f08cc13f.zip
Notes
Diffstat (limited to 'security/p5-Authen-PAAS/Makefile')
-rw-r--r--security/p5-Authen-PAAS/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/security/p5-Authen-PAAS/Makefile b/security/p5-Authen-PAAS/Makefile
new file mode 100644
index 000000000000..ded5ea0b2a33
--- /dev/null
+++ b/security/p5-Authen-PAAS/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: p5-Authen-PAAS
+# Date created: 22 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-PAAS
+PORTVERSION= 1.1.1
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl Authentication & Authorization Service
+
+BUILD_DEPENDS= p5-Config-Record>=1.1.0:${PORTSDIR}/devel/p5-Config-Record \
+ p5-Log-Log4perl>0:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN1= authen-paas-passwd.1
+MAN3= Authen::PAAS.3 \
+ Authen::PAAS::BasicLoginModule.3 \
+ Authen::PAAS::BasicUser.3 \
+ Authen::PAAS::Callback.3 \
+ Authen::PAAS::ConsoleCallback.3 \
+ Authen::PAAS::Context.3 \
+ Authen::PAAS::Credential.3 \
+ Authen::PAAS::LoginModule.3 \
+ Authen::PAAS::Principal.3 \
+ Authen::PAAS::SimpleCallback.3 \
+ Authen::PAAS::Subject.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from p5-Config-Record
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>