aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-PluggableCaptcha
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-02-22 05:42:33 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-02-22 05:42:33 +0000
commite981b6db40bc7d36b8dc273c1494296cd4464cb0 (patch)
tree3464282fa745f4f4a609b615775f85ddfecd7608 /security/p5-Authen-PluggableCaptcha
parentfdf270740a5080dc44fcc01d2082b15b63899a6b (diff)
Add p5-Authen-PluggableCaptcha 0.04, a pluggable Captcha framework for
Perl. PR: ports/109383 Submitted by: chinsan
Notes
Notes: svn path=/head/; revision=185667
Diffstat (limited to 'security/p5-Authen-PluggableCaptcha')
-rw-r--r--security/p5-Authen-PluggableCaptcha/Makefile35
-rw-r--r--security/p5-Authen-PluggableCaptcha/distinfo3
-rw-r--r--security/p5-Authen-PluggableCaptcha/pkg-descr11
-rw-r--r--security/p5-Authen-PluggableCaptcha/pkg-plist34
4 files changed, 83 insertions, 0 deletions
diff --git a/security/p5-Authen-PluggableCaptcha/Makefile b/security/p5-Authen-PluggableCaptcha/Makefile
new file mode 100644
index 000000000000..e09a51918905
--- /dev/null
+++ b/security/p5-Authen-PluggableCaptcha/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Authen-PluggableCaptcha
+# Date created: 2007/02/14
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-PluggableCaptcha
+PORTVERSION= 0.04
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= A pluggable Captcha framework for Perl
+
+BUILD_DEPENDS= p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes \
+ p5-Number-Spell>=0:${PORTSDIR}/textproc/p5-Number-Spell \
+ p5-HTML-Email-Obfuscate>=0:${PORTSDIR}/security/p5-HTML-Email-Obfuscate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::PluggableCaptcha.3 \
+ Authen::PluggableCaptcha::Challenge.3 \
+ Authen::PluggableCaptcha::ErrorLoggingObject.3 \
+ Authen::PluggableCaptcha::Helpers.3 \
+ Authen::PluggableCaptcha::KeyManager.3 \
+ Authen::PluggableCaptcha::Render.3 \
+ Authen::PluggableCaptcha::StandardAttributesObject.3 \
+ Authen::PluggableCaptcha::Tutorial.3 \
+ Authen::PluggableCaptcha::ValidityObject.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/security/p5-Authen-PluggableCaptcha/distinfo b/security/p5-Authen-PluggableCaptcha/distinfo
new file mode 100644
index 000000000000..7ee715abbbb5
--- /dev/null
+++ b/security/p5-Authen-PluggableCaptcha/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-PluggableCaptcha-0.04.tar.gz) = a2af590a6af94f49d9e136c8e0b3bffc
+SHA256 (Authen-PluggableCaptcha-0.04.tar.gz) = 6386eb9656c40cc7659cb700a3c020bd48c75169f82fbbf9ed9f9b035aacfca0
+SIZE (Authen-PluggableCaptcha-0.04.tar.gz) = 25703
diff --git a/security/p5-Authen-PluggableCaptcha/pkg-descr b/security/p5-Authen-PluggableCaptcha/pkg-descr
new file mode 100644
index 000000000000..a3cac59ba223
--- /dev/null
+++ b/security/p5-Authen-PluggableCaptcha/pkg-descr
@@ -0,0 +1,11 @@
+Authen::PluggableCaptcha is a fully modularized and extensible system for
+making Pluggable Catpcha (Completely Automated Public Turing Test to Tell
+Computers and Humans Apart) tests.
+
+Pluggable? All Captcha objects are instantiated and interfaced via the main
+module, and then manipulated to require various submodules as plug-ins.
+
+Authen::PluggableCaptcha borrows from the functionality in
+Apache::Session::Flex
+
+WWW: http://search.cpan.org/dist/Authen-PluggableCaptcha/
diff --git a/security/p5-Authen-PluggableCaptcha/pkg-plist b/security/p5-Authen-PluggableCaptcha/pkg-plist
new file mode 100644
index 000000000000..376f94da6eef
--- /dev/null
+++ b/security/p5-Authen-PluggableCaptcha/pkg-plist
@@ -0,0 +1,34 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/PluggableCaptcha/.packlist
+%%SITE_PERL%%/Authen/PluggableCaptcha.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/KeyManager.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/StandardAttributesObject.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Tutorial.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/ValidityObject.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Helpers.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Challenge.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/ErrorLoggingObject.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Text.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Text/Plain.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Text/HTML.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image/Imager.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image/Imager/effects.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image/Imager/layers.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image/Imager/layers/distraction_lines.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image/Imager/layers/bg.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image/Imager/layers/text.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image/Imager/effects/sinewarp.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Challenge/TypeString.pm
+%%SITE_PERL%%/Authen/PluggableCaptcha/Challenge/DoMath.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/PluggableCaptcha
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen
+@dirrmtry %%SITE_PERL%%/Authen/PluggableCaptcha/Render/Text
+@dirrmtry %%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image/Imager/layers
+@dirrmtry %%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image/Imager/effects
+@dirrmtry %%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image/Imager
+@dirrmtry %%SITE_PERL%%/Authen/PluggableCaptcha/Render/Image
+@dirrmtry %%SITE_PERL%%/Authen/PluggableCaptcha/Render
+@dirrmtry %%SITE_PERL%%/Authen/PluggableCaptcha/Challenge
+@dirrmtry %%SITE_PERL%%/Authen/PluggableCaptcha
+@dirrmtry %%SITE_PERL%%/Authen