aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Simple-DBI/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-22 05:07:49 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-22 05:07:49 +0000
commitcbd52b8357238253954085b0b180a935f403a8eb (patch)
tree92ae3f9d84d4d9b87c84fc2c8b6953474144393c /security/p5-Authen-Simple-DBI/Makefile
parente7dbfbe9d35343c72d025c485943dc55babf9d27 (diff)
downloadports-cbd52b8357238253954085b0b180a935f403a8eb.tar.gz
ports-cbd52b8357238253954085b0b180a935f403a8eb.zip
Notes
Diffstat (limited to 'security/p5-Authen-Simple-DBI/Makefile')
-rw-r--r--security/p5-Authen-Simple-DBI/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/p5-Authen-Simple-DBI/Makefile b/security/p5-Authen-Simple-DBI/Makefile
new file mode 100644
index 000000000000..59323be6fcb2
--- /dev/null
+++ b/security/p5-Authen-Simple-DBI/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Authen-Simple-DBI
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple-DBI
+PORTVERSION= 0.2
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple DBI authentication
+
+BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple::DBI.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>