aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Simple-PAM
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-22 17:24:15 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-22 17:24:15 +0000
commit378ea9059c32c268e1cc7a5362a60abd880a66bd (patch)
tree937a3b3246c4e599aca23a20dc85856b5b1a20c5 /security/p5-Authen-Simple-PAM
parentf5f6a08968bac652fd1f5b9f378558bccaa320de (diff)
downloadports-378ea9059c32c268e1cc7a5362a60abd880a66bd.tar.gz
ports-378ea9059c32c268e1cc7a5362a60abd880a66bd.zip
Notes
Diffstat (limited to 'security/p5-Authen-Simple-PAM')
-rw-r--r--security/p5-Authen-Simple-PAM/Makefile32
-rw-r--r--security/p5-Authen-Simple-PAM/distinfo3
-rw-r--r--security/p5-Authen-Simple-PAM/pkg-descr4
-rw-r--r--security/p5-Authen-Simple-PAM/pkg-plist3
4 files changed, 42 insertions, 0 deletions
diff --git a/security/p5-Authen-Simple-PAM/Makefile b/security/p5-Authen-Simple-PAM/Makefile
new file mode 100644
index 000000000000..599213af027c
--- /dev/null
+++ b/security/p5-Authen-Simple-PAM/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Authen-Simple-PAM
+# Date created: 22 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple-PAM
+PORTVERSION= 0.2
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple PAM authentication
+
+BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/Authen/PAM.pm:${PORTSDIR}/security/p5-Authen-PAM
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple::PAM.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Simple-PAM/distinfo b/security/p5-Authen-Simple-PAM/distinfo
new file mode 100644
index 000000000000..fdbbf2e3c7e7
--- /dev/null
+++ b/security/p5-Authen-Simple-PAM/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Simple-PAM-0.2.tar.gz) = 0b4eed87d2877cd89e412f04572c71f5
+SHA256 (Authen-Simple-PAM-0.2.tar.gz) = 354b2cb97bf3c62514f5d1b42c5f3637b45ef2d74e4b4258e7141f0aaadc60ab
+SIZE (Authen-Simple-PAM-0.2.tar.gz) = 2657
diff --git a/security/p5-Authen-Simple-PAM/pkg-descr b/security/p5-Authen-Simple-PAM/pkg-descr
new file mode 100644
index 000000000000..33cfa7f7c2e6
--- /dev/null
+++ b/security/p5-Authen-Simple-PAM/pkg-descr
@@ -0,0 +1,4 @@
+Authentication via PAM.
+
+WWW: http://search.cpan.org/dist/Authen-Simple-Net-PAM
+Author: Christian Hansen <ch@ngmedia.com>
diff --git a/security/p5-Authen-Simple-PAM/pkg-plist b/security/p5-Authen-Simple-PAM/pkg-plist
new file mode 100644
index 000000000000..8efcfbb9963f
--- /dev/null
+++ b/security/p5-Authen-Simple-PAM/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Authen/Simple/PAM.pm
+@dirrmtry %%SITE_PERL%%/Authen/Simple
+@dirrmtry %%SITE_PERL%%/Authen