aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Simple-Passwd
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-22 05:37:30 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-22 05:37:30 +0000
commitae50b320321edbb8a4a45cb616e0a37ece2bc4f4 (patch)
tree0b033d3917c1c34cd8f60ec67de61612db470e09 /security/p5-Authen-Simple-Passwd
parent87cb63c95ea576ab841980b16859906193f776e1 (diff)
downloadports-ae50b320321edbb8a4a45cb616e0a37ece2bc4f4.tar.gz
ports-ae50b320321edbb8a4a45cb616e0a37ece2bc4f4.zip
Notes
Diffstat (limited to 'security/p5-Authen-Simple-Passwd')
-rw-r--r--security/p5-Authen-Simple-Passwd/Makefile31
-rw-r--r--security/p5-Authen-Simple-Passwd/distinfo3
-rw-r--r--security/p5-Authen-Simple-Passwd/pkg-descr4
-rw-r--r--security/p5-Authen-Simple-Passwd/pkg-plist3
4 files changed, 41 insertions, 0 deletions
diff --git a/security/p5-Authen-Simple-Passwd/Makefile b/security/p5-Authen-Simple-Passwd/Makefile
new file mode 100644
index 000000000000..8cca80a5db8a
--- /dev/null
+++ b/security/p5-Authen-Simple-Passwd/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Authen-Simple-Passwd
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple-Passwd
+PORTVERSION= 0.6
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple Passwd authentication
+
+BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple::Passwd.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Simple-Passwd/distinfo b/security/p5-Authen-Simple-Passwd/distinfo
new file mode 100644
index 000000000000..38d41965eb2c
--- /dev/null
+++ b/security/p5-Authen-Simple-Passwd/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Simple-Passwd-0.6.tar.gz) = 64f37440bec901c0f59cbd5ef4c14424
+SHA256 (Authen-Simple-Passwd-0.6.tar.gz) = cf55bc36259edf0fd6af9ad2bac81b31dc5b56a162c660590ecb969c7c1674b2
+SIZE (Authen-Simple-Passwd-0.6.tar.gz) = 3849
diff --git a/security/p5-Authen-Simple-Passwd/pkg-descr b/security/p5-Authen-Simple-Passwd/pkg-descr
new file mode 100644
index 000000000000..67b6f36e952e
--- /dev/null
+++ b/security/p5-Authen-Simple-Passwd/pkg-descr
@@ -0,0 +1,4 @@
+Authentication Passwd authentication.
+
+WWW: http://search.cpan.org/dist/Authen-Simple-Net-Passwd
+Author: Christian Hansen <ch@ngmedia.com>
diff --git a/security/p5-Authen-Simple-Passwd/pkg-plist b/security/p5-Authen-Simple-Passwd/pkg-plist
new file mode 100644
index 000000000000..cc544c539f7d
--- /dev/null
+++ b/security/p5-Authen-Simple-Passwd/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Authen/Simple/Passwd.pm
+@dirrmtry %%SITE_PERL%%/Authen/Simple
+@dirrmtry %%SITE_PERL%%/Authen