aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Simple-RADIUS
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-22 17:30:35 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-22 17:30:35 +0000
commited9a86da78dba666b1563a832ece9813947ac26d (patch)
tree890d350786b159eade3aaaf283875530701c7483 /security/p5-Authen-Simple-RADIUS
parent378ea9059c32c268e1cc7a5362a60abd880a66bd (diff)
Notes
Diffstat (limited to 'security/p5-Authen-Simple-RADIUS')
-rw-r--r--security/p5-Authen-Simple-RADIUS/Makefile32
-rw-r--r--security/p5-Authen-Simple-RADIUS/distinfo3
-rw-r--r--security/p5-Authen-Simple-RADIUS/pkg-descr4
-rw-r--r--security/p5-Authen-Simple-RADIUS/pkg-plist3
4 files changed, 42 insertions, 0 deletions
diff --git a/security/p5-Authen-Simple-RADIUS/Makefile b/security/p5-Authen-Simple-RADIUS/Makefile
new file mode 100644
index 000000000000..499b574db56f
--- /dev/null
+++ b/security/p5-Authen-Simple-RADIUS/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Authen-Simple-RADIUS
+# Date created: 22 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple-RADIUS
+PORTVERSION= 0.1
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple RADIUS authentication
+
+BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
+ ${SITE_PERL}/Authen/Radius.pm:${PORTSDIR}/security/p5-Authen-Radius
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple::RADIUS.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Simple-RADIUS/distinfo b/security/p5-Authen-Simple-RADIUS/distinfo
new file mode 100644
index 000000000000..29e87302907d
--- /dev/null
+++ b/security/p5-Authen-Simple-RADIUS/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Simple-RADIUS-0.1.tar.gz) = e5a5bc72f2b8f8fe0e5a9eff085e23b2
+SHA256 (Authen-Simple-RADIUS-0.1.tar.gz) = 5f8e2d8535eda60ae9842cf24f38e6ecaf2e85ca3a391ecb3fcbbc98f26caf5e
+SIZE (Authen-Simple-RADIUS-0.1.tar.gz) = 2726
diff --git a/security/p5-Authen-Simple-RADIUS/pkg-descr b/security/p5-Authen-Simple-RADIUS/pkg-descr
new file mode 100644
index 000000000000..60c1dbf638f8
--- /dev/null
+++ b/security/p5-Authen-Simple-RADIUS/pkg-descr
@@ -0,0 +1,4 @@
+Authentication via RADIUS.
+
+WWW: http://search.cpan.org/dist/Authen-Simple-Net-RADIUS
+Author: Christian Hansen <ch@ngmedia.com>
diff --git a/security/p5-Authen-Simple-RADIUS/pkg-plist b/security/p5-Authen-Simple-RADIUS/pkg-plist
new file mode 100644
index 000000000000..c8e1710f3357
--- /dev/null
+++ b/security/p5-Authen-Simple-RADIUS/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Authen/Simple/RADIUS.pm
+@dirrmtry %%SITE_PERL%%/Authen/Simple
+@dirrmtry %%SITE_PERL%%/Authen