aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Simple/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
commit17e550ca2fd180b150f6645ced5f3bb45bc32292 (patch)
treee856fa025c5b15bbef21f621e347c51780662a47 /security/p5-Authen-Simple/Makefile
parentb4599e3d63c3a94b17026b18d1f8ac27faac53fc (diff)
downloadports-17e550ca2fd180b150f6645ced5f3bb45bc32292.tar.gz
ports-17e550ca2fd180b150f6645ced5f3bb45bc32292.zip
Notes
Diffstat (limited to 'security/p5-Authen-Simple/Makefile')
-rw-r--r--security/p5-Authen-Simple/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/security/p5-Authen-Simple/Makefile b/security/p5-Authen-Simple/Makefile
index eb2cc2efff56..57c434e66542 100644
--- a/security/p5-Authen-Simple/Makefile
+++ b/security/p5-Authen-Simple/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Authen-Simple
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,12 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple authentication framework
-BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
MAN3= Authen::Simple.3 \
Authen::Simple::Adapter.3 \
@@ -30,4 +29,10 @@ MAN3= Authen::Simple.3 \
PERL_MODBUILD= 5.8.0+
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>