aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Simple
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-22 00:52:28 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-22 00:52:28 +0000
commitc3c2cd4d1427dc13920eb4ba23e856f47a48f57d (patch)
tree9170875bca8899d210292a2e6957423889010f27 /security/p5-Authen-Simple
parentf2fc4a102450a437dc6b8a15df60ef4bf278b01e (diff)
downloadports-c3c2cd4d1427dc13920eb4ba23e856f47a48f57d.tar.gz
ports-c3c2cd4d1427dc13920eb4ba23e856f47a48f57d.zip
Notes
Diffstat (limited to 'security/p5-Authen-Simple')
-rw-r--r--security/p5-Authen-Simple/Makefile40
-rw-r--r--security/p5-Authen-Simple/distinfo3
-rw-r--r--security/p5-Authen-Simple/pkg-descr4
-rw-r--r--security/p5-Authen-Simple/pkg-plist7
4 files changed, 54 insertions, 0 deletions
diff --git a/security/p5-Authen-Simple/Makefile b/security/p5-Authen-Simple/Makefile
new file mode 100644
index 000000000000..7aa944d03eb5
--- /dev/null
+++ b/security/p5-Authen-Simple/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Authen-Simple
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple
+PORTVERSION= 0.4
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple authentication framework
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple.3 \
+ Authen::Simple::Adapter.3 \
+ Authen::Simple::Apache.3 \
+ Authen::Simple::Log.3 \
+ Authen::Simple::Password.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Simple/distinfo b/security/p5-Authen-Simple/distinfo
new file mode 100644
index 000000000000..e0af5ba03bd2
--- /dev/null
+++ b/security/p5-Authen-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Simple-0.4.tar.gz) = ca2ebc687e9282c92f488fa79e3e8723
+SHA256 (Authen-Simple-0.4.tar.gz) = be57f93ee087b86cb359796a86f48922b7a27300714b3070f16971b206eb8b05
+SIZE (Authen-Simple-0.4.tar.gz) = 8304
diff --git a/security/p5-Authen-Simple/pkg-descr b/security/p5-Authen-Simple/pkg-descr
new file mode 100644
index 000000000000..1f8b49eb32e2
--- /dev/null
+++ b/security/p5-Authen-Simple/pkg-descr
@@ -0,0 +1,4 @@
+Simple and consistent framework for authentication.
+
+WWW: http://search.cpan.org/dist/Authen-Simple
+Author: Christian Hansen <ch@ngmedia.com>
diff --git a/security/p5-Authen-Simple/pkg-plist b/security/p5-Authen-Simple/pkg-plist
new file mode 100644
index 000000000000..3071a14ce48e
--- /dev/null
+++ b/security/p5-Authen-Simple/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Authen/Simple.pm
+%%SITE_PERL%%/Authen/Simple/Adapter.pm
+%%SITE_PERL%%/Authen/Simple/Apache.pm
+%%SITE_PERL%%/Authen/Simple/Log.pm
+%%SITE_PERL%%/Authen/Simple/Password.pm
+@dirrm %%SITE_PERL%%/Authen/Simple
+@dirrmtry %%SITE_PERL%%/Authen