aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Business-PayPal-EWP
diff options
context:
space:
mode:
authorAlfred Perlstein <alfred@FreeBSD.org>2005-05-19 20:25:02 +0000
committerAlfred Perlstein <alfred@FreeBSD.org>2005-05-19 20:25:02 +0000
commitb21d1c4528e068e2268b3a449b8b131d2f52944b (patch)
treee1f13f8bcba4aa35403661a110c828d189e8d788 /security/p5-Business-PayPal-EWP
parent4108617c9a206a7f67727e6c4879379b708638f0 (diff)
downloadports-b21d1c4528e068e2268b3a449b8b131d2f52944b.tar.gz
ports-b21d1c4528e068e2268b3a449b8b131d2f52944b.zip
Notes
Diffstat (limited to 'security/p5-Business-PayPal-EWP')
-rw-r--r--security/p5-Business-PayPal-EWP/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/security/p5-Business-PayPal-EWP/Makefile b/security/p5-Business-PayPal-EWP/Makefile
index 825865ccc30c..c1ed4c3f7ff3 100644
--- a/security/p5-Business-PayPal-EWP/Makefile
+++ b/security/p5-Business-PayPal-EWP/Makefile
@@ -20,10 +20,25 @@ USE_REINPLACE= yes
PERL_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= ${OPENSSLBASE}
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS= ${BUILD_DEPENDS}
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Business::PayPal::EWP.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+foo:
+ echo ${PERL_LEVEL}
+.endif
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ #${PERL} -pi -e 's!^our \((.*?)(?=\);)!join("","use vars qw(",split(/,/,$$1))!e' ${WRKSRC}/lib/Business/PayPal/EWP.pm
+ ${PERL} -pi -e 's/^our /my /' ${WRKSRC}/lib/Business/PayPal/EWP.pm
+.endif
+
+.include <bsd.port.post.mk>