aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Business-PayPal-EWP
diff options
context:
space:
mode:
authorAlfred Perlstein <alfred@FreeBSD.org>2005-05-12 17:48:44 +0000
committerAlfred Perlstein <alfred@FreeBSD.org>2005-05-12 17:48:44 +0000
commit5b78d81232654dfa74fc574d449d3ebed6869585 (patch)
treedc97d3da6b0960a63f734d5ebc9b955cba1e8c56 /security/p5-Business-PayPal-EWP
parent54c086c129c88d664ff3008d1336164547b80e66 (diff)
downloadports-5b78d81232654dfa74fc574d449d3ebed6869585.tar.gz
ports-5b78d81232654dfa74fc574d449d3ebed6869585.zip
Notes
Diffstat (limited to 'security/p5-Business-PayPal-EWP')
-rw-r--r--security/p5-Business-PayPal-EWP/Makefile29
-rw-r--r--security/p5-Business-PayPal-EWP/distinfo2
-rw-r--r--security/p5-Business-PayPal-EWP/files/patch-EWP.pm10
-rw-r--r--security/p5-Business-PayPal-EWP/files/patch-EWP.xs13
-rw-r--r--security/p5-Business-PayPal-EWP/pkg-descr1
5 files changed, 55 insertions, 0 deletions
diff --git a/security/p5-Business-PayPal-EWP/Makefile b/security/p5-Business-PayPal-EWP/Makefile
new file mode 100644
index 000000000000..825865ccc30c
--- /dev/null
+++ b/security/p5-Business-PayPal-EWP/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Business-PayPal-EWP
+# Date created: Thu 12 May 2005
+# Whom: Alfred Perlstein
+#
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-PayPal-EWP
+PORTVERSION= 0.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Business
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alfred@freebsd.org
+COMMENT= Perl extension to talk to paypal
+
+USE_REINPLACE= yes
+PERL_CONFIGURE= yes
+USE_OPENSSL= yes
+CONFIGURE_ARGS= ${OPENSSLBASE}
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Business::PayPal::EWP.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Business-PayPal-EWP/distinfo b/security/p5-Business-PayPal-EWP/distinfo
new file mode 100644
index 000000000000..6247c4f18257
--- /dev/null
+++ b/security/p5-Business-PayPal-EWP/distinfo
@@ -0,0 +1,2 @@
+MD5 (Business-PayPal-EWP-0.02.tar.gz) = 08327a5ffaa2b76bb1b73529b4d2216a
+SIZE (Business-PayPal-EWP-0.02.tar.gz) = 18615
diff --git a/security/p5-Business-PayPal-EWP/files/patch-EWP.pm b/security/p5-Business-PayPal-EWP/files/patch-EWP.pm
new file mode 100644
index 000000000000..847b2e8819e1
--- /dev/null
+++ b/security/p5-Business-PayPal-EWP/files/patch-EWP.pm
@@ -0,0 +1,10 @@
+--- lib/Business/PayPal/EWP.pm.old Thu May 12 10:42:19 2005
++++ lib/Business/PayPal/EWP.pm Thu May 12 10:42:39 2005
+@@ -65,6 +65,7 @@
+ goto END;
+ }
+ Net::SSLeay::BIO_free($bio);
++ $bio = undef;
+ # Reformat
+ $formdata=~s/,/\n/g;
+ # Encrypt and sign
diff --git a/security/p5-Business-PayPal-EWP/files/patch-EWP.xs b/security/p5-Business-PayPal-EWP/files/patch-EWP.xs
new file mode 100644
index 000000000000..f91783ab6ff4
--- /dev/null
+++ b/security/p5-Business-PayPal-EWP/files/patch-EWP.xs
@@ -0,0 +1,13 @@
+--- EWP.xs.old Thu May 12 10:40:14 2005
++++ EWP.xs Thu May 12 10:41:55 2005
+@@ -126,8 +126,10 @@
+ PKCS7_free(p7);
+ if (bio)
+ BIO_free_all(bio);
++#if 0
+ if (memBio)
+ BIO_free_all(memBio);
++#endif
+ if (p7bio)
+ BIO_free_all(p7bio);
+ if (pkey)
diff --git a/security/p5-Business-PayPal-EWP/pkg-descr b/security/p5-Business-PayPal-EWP/pkg-descr
new file mode 100644
index 000000000000..e6ae9c0d5ff8
--- /dev/null
+++ b/security/p5-Business-PayPal-EWP/pkg-descr
@@ -0,0 +1 @@
+This module offers an interface to Paypal's encryption scheme.