aboutsummaryrefslogtreecommitdiff
path: root/security/p5-CSP
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-16 23:51:12 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-16 23:51:12 +0000
commitaa327195fb3834dfe59e3541216bb4d11409b27e (patch)
tree0ba63212a32ea6e1e2abaa274ec0c066ceaa4d31 /security/p5-CSP
parentfa58581d377971192439230eef656a31961fe160 (diff)
downloadports-aa327195fb3834dfe59e3541216bb4d11409b27e.tar.gz
ports-aa327195fb3834dfe59e3541216bb4d11409b27e.zip
Notes
Diffstat (limited to 'security/p5-CSP')
-rw-r--r--security/p5-CSP/Makefile25
-rw-r--r--security/p5-CSP/distinfo2
-rw-r--r--security/p5-CSP/pkg-descr5
-rw-r--r--security/p5-CSP/pkg-plist6
4 files changed, 38 insertions, 0 deletions
diff --git a/security/p5-CSP/Makefile b/security/p5-CSP/Makefile
new file mode 100644
index 000000000000..9416ebccf27a
--- /dev/null
+++ b/security/p5-CSP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-CSP
+# Date created: 2005-04-13
+# Whom: David Thiel <lx@redundancy.redundancy.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CSP
+PORTVERSION= 0.26
+CATEGORIES= security perl5
+MASTER_SITES= ftp://ftp.it.su.se/pub/users/leifj/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A Perl tool for managing Certificate Authorities
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
+ ${SITE_PERL}/Term/Prompt.pm:${PORTSDIR}/devel/p5-Term-Prompt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CSP.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-CSP/distinfo b/security/p5-CSP/distinfo
new file mode 100644
index 000000000000..b4e01cdfe9c5
--- /dev/null
+++ b/security/p5-CSP/distinfo
@@ -0,0 +1,2 @@
+MD5 (CSP-0.26.tar.gz) = 37534bb4c06953d0a7f37da7c56e041a
+SIZE (CSP-0.26.tar.gz) = 16963
diff --git a/security/p5-CSP/pkg-descr b/security/p5-CSP/pkg-descr
new file mode 100644
index 000000000000..f961f07e7973
--- /dev/null
+++ b/security/p5-CSP/pkg-descr
@@ -0,0 +1,5 @@
+CSP is a Perl class and script for running multiple CAs. OpenSSL is used
+for all operations. CSP can also generate a small CA website used to
+distribute certificates and CRLs.
+
+WWW: http://devel.it.su.se/projects/CSP/
diff --git a/security/p5-CSP/pkg-plist b/security/p5-CSP/pkg-plist
new file mode 100644
index 000000000000..3ad48bc5d76d
--- /dev/null
+++ b/security/p5-CSP/pkg-plist
@@ -0,0 +1,6 @@
+bin/csp
+%%SITE_PERL%%/CSP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CSP/.packlist
+%%SITE_PERL%%/auto/CSP/autosplit.ix
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CSP
+@dirrm %%SITE_PERL%%/auto/CSP