aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-CBCeasy
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /security/p5-Crypt-CBCeasy
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'security/p5-Crypt-CBCeasy')
-rw-r--r--security/p5-Crypt-CBCeasy/Makefile41
1 files changed, 19 insertions, 22 deletions
diff --git a/security/p5-Crypt-CBCeasy/Makefile b/security/p5-Crypt-CBCeasy/Makefile
index 91273e0ae808..7d07d381c962 100644
--- a/security/p5-Crypt-CBCeasy/Makefile
+++ b/security/p5-Crypt-CBCeasy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Crypt-CBCeasy
PORTVERSION= 0.24
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -18,7 +18,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-OPTIONS_DEFINE= DES IDEA BLOWFISH BLOWFISH_PP TWOFISH2 RIJNDAEL
+OPTIONS_DEFINE= DES IDEA BLOWFISH BLOWFISH_PP TWOFISH2 RIJNDAEL
OPTIONS_DEFAULT= DES IDEA BLOWFISH BLOWFISH_PP TWOFISH2 RIJNDAEL
DES_DESC= Build with Crypt::DES support
IDEA_DESC= Build with Crypt::IDEA support
@@ -27,25 +27,22 @@ BLOWFISH_PP_DESC= Build with Crypt::Blowfish_PP support
TWOFISH2_DESC= Build with Crypt::Twofish2 support
RIJNDAEL_DESC= Build with Crypt::Rijndael support
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDES}
-BUILD_DEPENDS+= p5-Crypt-DES>=0:${PORTSDIR}/security/p5-Crypt-DES
-.endif
-.if ${PORT_OPTIONS:MIDEA}
-BUILD_DEPENDS+= p5-Crypt-IDEA>=0:${PORTSDIR}/security/p5-Crypt-IDEA
-.endif
-.if ${PORT_OPTIONS:MBLOWFISH}
-BUILD_DEPENDS+= p5-Crypt-Blowfish>=0:${PORTSDIR}/security/p5-Crypt-Blowfish
-.endif
-.if ${PORT_OPTIONS:MBLOWFISH_PP}
-BUILD_DEPENDS+= p5-Crypt-Blowfish_PP>=0:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
-.endif
-.if ${PORT_OPTIONS:MTWOFISH2}
-BUILD_DEPENDS+= p5-Crypt-Twofish2>=0:${PORTSDIR}/security/p5-Crypt-Twofish2
-.endif
-.if ${PORT_OPTIONS:MRIJNDAEL}
-BUILD_DEPENDS+= p5-Crypt-Rijndael>=0:${PORTSDIR}/security/p5-Crypt-Rijndael
-.endif
+DES_BUILD_DEPENDS= p5-Crypt-DES>=0:${PORTSDIR}/security/p5-Crypt-DES
+DES_RUN_DEPENDS= p5-Crypt-DES>=0:${PORTSDIR}/security/p5-Crypt-DES
+
+IDEA_BUILD_DEPENDS= p5-Crypt-IDEA>=0:${PORTSDIR}/security/p5-Crypt-IDEA
+IDEA_RUN_DEPENDS= p5-Crypt-IDEA>=0:${PORTSDIR}/security/p5-Crypt-IDEA
+
+BLOWFISH_BUILD_DEPENDS= p5-Crypt-Blowfish>=0:${PORTSDIR}/security/p5-Crypt-Blowfish
+BLOWFISH_RUN_DEPENDS= p5-Crypt-Blowfish>=0:${PORTSDIR}/security/p5-Crypt-Blowfish
+
+BLOWFISH_PP_BUILD_DEPENDS= p5-Crypt-Blowfish_PP>=0:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
+BLOWFISH_PP_RUN_DEPENDS= p5-Crypt-Blowfish_PP>=0:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
+
+TWOFISH2_BUILD_DEPENDS= p5-Crypt-Twofish2>=0:${PORTSDIR}/security/p5-Crypt-Twofish2
+TWOFISH2_RUN_DEPENDS= p5-Crypt-Twofish2>=0:${PORTSDIR}/security/p5-Crypt-Twofish2
+
+RIJNDAEL_BUILD_DEPENDS= p5-Crypt-Rijndael>=0:${PORTSDIR}/security/p5-Crypt-Rijndael
+RIJNDAEL_RUN_DEPENDS= p5-Crypt-Rijndael>=0:${PORTSDIR}/security/p5-Crypt-Rijndael
.include <bsd.port.mk>