aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-CFB
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-18 21:55:15 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-18 21:55:15 +0000
commit3a682b1c6de1971cd69dcd7e61045e26c073ddc9 (patch)
tree24a716914b8434d5c8bdea75d4cd84fa39a42a56 /security/p5-Crypt-CFB
parent9c4705836ee78753180169ec2192973fca3ebb02 (diff)
downloadports-3a682b1c6de1971cd69dcd7e61045e26c073ddc9.tar.gz
ports-3a682b1c6de1971cd69dcd7e61045e26c073ddc9.zip
Notes
Diffstat (limited to 'security/p5-Crypt-CFB')
-rw-r--r--security/p5-Crypt-CFB/Makefile24
-rw-r--r--security/p5-Crypt-CFB/distinfo3
-rw-r--r--security/p5-Crypt-CFB/pkg-descr8
-rw-r--r--security/p5-Crypt-CFB/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/security/p5-Crypt-CFB/Makefile b/security/p5-Crypt-CFB/Makefile
new file mode 100644
index 000000000000..5a0c6bc9ec9a
--- /dev/null
+++ b/security/p5-Crypt-CFB/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-CFB
+# Date created: 18 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-CFB
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for encrypting data in Cipher Feedback Mode
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::CFB.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-CFB/distinfo b/security/p5-Crypt-CFB/distinfo
new file mode 100644
index 000000000000..a9a8ce4ab017
--- /dev/null
+++ b/security/p5-Crypt-CFB/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-CFB-0.01.tar.gz) = eb29e4d92d67b7763a3882858077cf08
+SHA256 (Crypt-CFB-0.01.tar.gz) = 2ee25f51f360779759b48e7703a77a4436f5ce278ac8e8077bff5f8c62fa2b78
+SIZE (Crypt-CFB-0.01.tar.gz) = 8572
diff --git a/security/p5-Crypt-CFB/pkg-descr b/security/p5-Crypt-CFB/pkg-descr
new file mode 100644
index 000000000000..3a99acb1e00f
--- /dev/null
+++ b/security/p5-Crypt-CFB/pkg-descr
@@ -0,0 +1,8 @@
+Generic CFB implementation in pure Perl. The Cipher Feedback Mode module
+constructs a stream cipher from a block cipher or cryptographic hash funtion
+and returns it as an object. Any block cipher in the Crypt:: class can be
+used, as long as it supports the blocksize and keysize methods. Any hash
+function in the Digest:: class can be used, as long as it supports the
+add method.
+
+WWW: http://search.cpan.org/dist/Crypt-CFB
diff --git a/security/p5-Crypt-CFB/pkg-plist b/security/p5-Crypt-CFB/pkg-plist
new file mode 100644
index 000000000000..055080039c53
--- /dev/null
+++ b/security/p5-Crypt-CFB/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/CFB.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/CFB/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/CFB/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true