aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-DES_EDE3
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-14 15:00:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-14 15:00:57 +0000
commite633179c5203c27ac79a2cb657c9ff5f409931c5 (patch)
tree9f781f4102f0f305ef79c7902a20fd983d38d0be /security/p5-Crypt-DES_EDE3
parentc22e7f25dccf1ef454e4859824264ec51b3cd328 (diff)
downloadports-e633179c5203c27ac79a2cb657c9ff5f409931c5.tar.gz
ports-e633179c5203c27ac79a2cb657c9ff5f409931c5.zip
Notes
Diffstat (limited to 'security/p5-Crypt-DES_EDE3')
-rw-r--r--security/p5-Crypt-DES_EDE3/Makefile25
-rw-r--r--security/p5-Crypt-DES_EDE3/distinfo1
-rw-r--r--security/p5-Crypt-DES_EDE3/pkg-comment1
-rw-r--r--security/p5-Crypt-DES_EDE3/pkg-descr6
-rw-r--r--security/p5-Crypt-DES_EDE3/pkg-plist1
5 files changed, 34 insertions, 0 deletions
diff --git a/security/p5-Crypt-DES_EDE3/Makefile b/security/p5-Crypt-DES_EDE3/Makefile
new file mode 100644
index 000000000000..624cc61dc220
--- /dev/null
+++ b/security/p5-Crypt-DES_EDE3/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Crypt-DES_EDE3
+# Date created: 2002/03/14
+# Whom: jesper
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-DES_EDE3
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jesper@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::DES_EDE3.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-DES_EDE3/distinfo b/security/p5-Crypt-DES_EDE3/distinfo
new file mode 100644
index 000000000000..2ca34c69b29b
--- /dev/null
+++ b/security/p5-Crypt-DES_EDE3/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-DES_EDE3-0.01.tar.gz) = fde1995efa0735407a5f7c4a4c8147bc
diff --git a/security/p5-Crypt-DES_EDE3/pkg-comment b/security/p5-Crypt-DES_EDE3/pkg-comment
new file mode 100644
index 000000000000..37f565322504
--- /dev/null
+++ b/security/p5-Crypt-DES_EDE3/pkg-comment
@@ -0,0 +1 @@
+Perl5 interface to a implementing 3-DES EDE encryption and decryption
diff --git a/security/p5-Crypt-DES_EDE3/pkg-descr b/security/p5-Crypt-DES_EDE3/pkg-descr
new file mode 100644
index 000000000000..a64bda3ccc89
--- /dev/null
+++ b/security/p5-Crypt-DES_EDE3/pkg-descr
@@ -0,0 +1,6 @@
+Crypt::DES_EDE3 implements DES-EDE3 encryption. This is triple-DES
+encryption where an encrypt operation is encrypt-decrypt-encrypt, and
+decrypt is decrypt-encrypt-decrypt. This implementation uses Crypt::DES
+to do its dirty DES work, and simply provides a wrapper around that
+module: setting up the individual DES ciphers, initializing the keys,
+and performing the encryption/decryption steps
diff --git a/security/p5-Crypt-DES_EDE3/pkg-plist b/security/p5-Crypt-DES_EDE3/pkg-plist
new file mode 100644
index 000000000000..79686ec84530
--- /dev/null
+++ b/security/p5-Crypt-DES_EDE3/pkg-plist
@@ -0,0 +1 @@
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/DES_EDE3.pm