aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Dining/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-25 20:05:50 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-25 20:05:50 +0000
commite82e60987a5e00137f41d03dcdb5ce0cccca9825 (patch)
tree4876bef72db56f83f05cdef798095e963786df4e /security/p5-Crypt-Dining/Makefile
parent1e666cdba22098ed0cb4590c6006290340d9afa3 (diff)
Notes
Diffstat (limited to 'security/p5-Crypt-Dining/Makefile')
-rw-r--r--security/p5-Crypt-Dining/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/p5-Crypt-Dining/Makefile b/security/p5-Crypt-Dining/Makefile
new file mode 100644
index 000000000000..6cadeba5770b
--- /dev/null
+++ b/security/p5-Crypt-Dining/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Crypt-Dining
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Dining
+PORTVERSION= 1.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= The Dining Cryptographers' Protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/Random.pm:${PORTSDIR}/security/p5-Crypt-Random \
+ ${SITE_PERL}/Net/Address/IPv4/Local.pm:${PORTSDIR}/net/p5-Net-Address-IPv4-Local
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Crypt::Dining.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6.0 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>