aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-ECB
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-12-27 10:10:51 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-12-27 10:10:51 +0000
commit21cb04a6b7878037ef01b871cc1e837fc51d883f (patch)
tree1954460a54d02684b5aa318a3e6ba11a4a03f392 /security/p5-Crypt-ECB
parent9ce3379d17862a5280ae177c3d0f0b2207165446 (diff)
downloadports-21cb04a6b7878037ef01b871cc1e837fc51d883f.tar.gz
ports-21cb04a6b7878037ef01b871cc1e837fc51d883f.zip
Notes
Diffstat (limited to 'security/p5-Crypt-ECB')
-rw-r--r--security/p5-Crypt-ECB/Makefile1
-rw-r--r--security/p5-Crypt-ECB/files/patch-ECB.pm11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/p5-Crypt-ECB/Makefile b/security/p5-Crypt-ECB/Makefile
index a406f9474412..3232efabb65d 100644
--- a/security/p5-Crypt-ECB/Makefile
+++ b/security/p5-Crypt-ECB/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Crypt-ECB
PORTVERSION= 1.1p2
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Crypt
diff --git a/security/p5-Crypt-ECB/files/patch-ECB.pm b/security/p5-Crypt-ECB/files/patch-ECB.pm
new file mode 100644
index 000000000000..8a411655aa96
--- /dev/null
+++ b/security/p5-Crypt-ECB/files/patch-ECB.pm
@@ -0,0 +1,11 @@
+--- ECB.pm.orig Mon Dec 27 11:05:33 2004
++++ ECB.pm Mon Dec 27 11:06:45 2004
+@@ -274,7 +274,7 @@ sub finish (\$)
+ $crypt->{Mode} = '';
+ $crypt->{buffer} = '';
+
+- return '' unless $data;
++ return '' unless defined($data) && length($data) > 0;
+
+ my $cipher = $crypt->_getcipher;
+