aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Enigma/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-21 08:35:13 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-21 08:35:13 +0000
commit420de3189ad163e3b8be6cdad73b6dba87581003 (patch)
treec7fadea81be100af9417532e9c9d1617751914ed /security/p5-Crypt-Enigma/Makefile
parentc21eaf87ee838cf1649dcaa1452a8ac1752d8153 (diff)
This module is a complete working Perl implementation of the Enigma Machine
used during World War II. The cipher calculations are based on actual Enigma values and the resulting ciphered values are as would be expected from an Enigma Machine. The implementation allows for all of the Rotors and Reflectors available to the real world Enigma to be used. A Steckerboard has also been implemented, allowing letter substitutions to be made. WWW: http://search.cpan.org/dist/Crypt-Enigma PR: ports/90683 Submitted by: Gabor Kovesdan
Notes
Notes: svn path=/head/; revision=151720
Diffstat (limited to 'security/p5-Crypt-Enigma/Makefile')
-rw-r--r--security/p5-Crypt-Enigma/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/security/p5-Crypt-Enigma/Makefile b/security/p5-Crypt-Enigma/Makefile
new file mode 100644
index 000000000000..088a12a1c01f
--- /dev/null
+++ b/security/p5-Crypt-Enigma/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-Enigma
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-Enigma
+PORTVERSION= 1.3
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for the Enigma cipher
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Enigma.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>