aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-OFB
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-11-04 16:42:44 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-11-04 16:42:44 +0000
commitc530abb09cda07160a90bbb2473393c5ea4ce1a6 (patch)
treec6fd5e87636201247f7f163ee3286a324ee9f37b /security/p5-Crypt-OFB
parent65770611063025305f8ad76048914382e34c2890 (diff)
downloadports-c530abb09cda07160a90bbb2473393c5ea4ce1a6.tar.gz
ports-c530abb09cda07160a90bbb2473393c5ea4ce1a6.zip
Notes
Diffstat (limited to 'security/p5-Crypt-OFB')
-rw-r--r--security/p5-Crypt-OFB/Makefile25
-rw-r--r--security/p5-Crypt-OFB/distinfo1
-rw-r--r--security/p5-Crypt-OFB/pkg-descr6
-rw-r--r--security/p5-Crypt-OFB/pkg-plist5
4 files changed, 37 insertions, 0 deletions
diff --git a/security/p5-Crypt-OFB/Makefile b/security/p5-Crypt-OFB/Makefile
new file mode 100644
index 000000000000..af3768037ca3
--- /dev/null
+++ b/security/p5-Crypt-OFB/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Crypt-OFB
+# Date created: Nov 2 2003
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-OFB
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Encrypt Data using OFB Mode
+
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/ECB.pm:${PORTSDIR}/security/p5-Crypt-ECB
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::OFB.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OFB/distinfo b/security/p5-Crypt-OFB/distinfo
new file mode 100644
index 000000000000..ef6f15b6a1e4
--- /dev/null
+++ b/security/p5-Crypt-OFB/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-OFB-0.01.tar.gz) = 4d23f4d5c773cddf85e347ba36a6df6b
diff --git a/security/p5-Crypt-OFB/pkg-descr b/security/p5-Crypt-OFB/pkg-descr
new file mode 100644
index 000000000000..9c23be9b0cd9
--- /dev/null
+++ b/security/p5-Crypt-OFB/pkg-descr
@@ -0,0 +1,6 @@
+This module is a Perl-only implementation of the OFB mode.
+Where OFB stands for Output Feedback Block.
+
+WWW: http://search.cpan.org/search?dist=Crypt-OFB
+
+Autho: GUGOD <gugod@guguod.org>
diff --git a/security/p5-Crypt-OFB/pkg-plist b/security/p5-Crypt-OFB/pkg-plist
new file mode 100644
index 000000000000..6b4f77918070
--- /dev/null
+++ b/security/p5-Crypt-OFB/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/OFB.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OFB/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OFB
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true