aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-OpenSSL-ECDSA/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-02-14 18:59:03 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-02-14 18:59:03 +0000
commit94c98a7481f36ab6551dd0926874febad3872b8b (patch)
tree54f5a1f2a5d94b49a8a7a0ba7de9389e401514e7 /security/p5-Crypt-OpenSSL-ECDSA/Makefile
parentecc14c28252a0ea3a48c7d56ffeb471238d59265 (diff)
downloadports-94c98a7481f36ab6551dd0926874febad3872b8b.tar.gz
ports-94c98a7481f36ab6551dd0926874febad3872b8b.zip
Notes
Diffstat (limited to 'security/p5-Crypt-OpenSSL-ECDSA/Makefile')
-rw-r--r--security/p5-Crypt-OpenSSL-ECDSA/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/security/p5-Crypt-OpenSSL-ECDSA/Makefile b/security/p5-Crypt-OpenSSL-ECDSA/Makefile
new file mode 100644
index 000000000000..daec62c2edc5
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-ECDSA/Makefile
@@ -0,0 +1,21 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Crypt-OpenSSL-ECDSA
+PORTVERSION= 0.06
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MIKEM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl extension for OpenSSL ECDSA
+
+BUILD_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0.04:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-EC>=0.05:${PORTSDIR}/security/p5-Crypt-OpenSSL-EC
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>