aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-OpenSSL-RSA/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-05-26 08:58:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-05-26 08:58:21 +0000
commitb145d52c97ebb40f36bb31c1438fdd5dd228acd9 (patch)
tree0b45686772b409299949ddf4e34df3bc23a6ee90 /security/p5-Crypt-OpenSSL-RSA/Makefile
parent484fd842d1547b9c4ecd7635f9b5c1052e72b10f (diff)
downloadports-b145d52c97ebb40f36bb31c1438fdd5dd228acd9.tar.gz
ports-b145d52c97ebb40f36bb31c1438fdd5dd228acd9.zip
Notes
Diffstat (limited to 'security/p5-Crypt-OpenSSL-RSA/Makefile')
-rw-r--r--security/p5-Crypt-OpenSSL-RSA/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/security/p5-Crypt-OpenSSL-RSA/Makefile b/security/p5-Crypt-OpenSSL-RSA/Makefile
index ae8722e9b1c0..539c632e8143 100644
--- a/security/p5-Crypt-OpenSSL-RSA/Makefile
+++ b/security/p5-Crypt-OpenSSL-RSA/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Crypt-OpenSSL-RSA
PORTVERSION= 0.26
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,14 +15,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module to RSA encode and decode strings using OpenSSL
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/Random.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/Bignum.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-Random>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random
+RUN_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-Random>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random
PERL_CONFIGURE= yes
USE_OPENSSL= yes
-MAKE_ARGS+= PASTHRU_INC=-I${OPENSSLINC}
+MAKE_ARGS= PASTHRU_INC=-I${OPENSSLINC}
MAN3= Crypt::OpenSSL::RSA.3
+post-patch:
+ @${REINPLACE_CMD} -e "9 s|require AutoLoader;|use AutoLoader 'AUTOLOAD';|" ${WRKSRC}/RSA.pm
+
+regression-test: build
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} test
+
.include <bsd.port.mk>