aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-PWSafe3
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-08-06 09:43:10 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-08-06 09:43:10 +0000
commitc9298c9ce10964270b705c161eb303de9620436f (patch)
treee4704161227973e51687d88f3044e3120c4d2635 /security/p5-Crypt-PWSafe3
parent77f1bf8267f14a368ea86884c814d1e63d18c571 (diff)
downloadports-c9298c9ce10964270b705c161eb303de9620436f.tar.gz
ports-c9298c9ce10964270b705c161eb303de9620436f.zip
Notes
Diffstat (limited to 'security/p5-Crypt-PWSafe3')
-rw-r--r--security/p5-Crypt-PWSafe3/Makefile28
-rw-r--r--security/p5-Crypt-PWSafe3/distinfo2
-rw-r--r--security/p5-Crypt-PWSafe3/pkg-descr3
-rw-r--r--security/p5-Crypt-PWSafe3/pkg-plist14
4 files changed, 47 insertions, 0 deletions
diff --git a/security/p5-Crypt-PWSafe3/Makefile b/security/p5-Crypt-PWSafe3/Makefile
new file mode 100644
index 000000000000..e49df693cedb
--- /dev/null
+++ b/security/p5-Crypt-PWSafe3/Makefile
@@ -0,0 +1,28 @@
+# Created by: Alexander Y. Grigoryev <alexander.4mail@gmail.com>
+# $FreeBSD$
+
+PORTNAME= Crypt-PWSafe3
+PORTVERSION= 1.21
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alexander.4mail@gmail.com
+COMMENT= Read and write Passwordsafe v3 files
+
+LICENSE= ART20
+
+BUILD_DEPENDS= p5-Digest-HMAC>=1.00:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-Digest-SHA>=1.00:${PORTSDIR}/security/p5-Digest-SHA \
+ p5-Crypt-CBC>=2.30:${PORTSDIR}/security/p5-Crypt-CBC \
+ p5-Crypt-ECB>=1.45:${PORTSDIR}/security/p5-Crypt-ECB \
+ p5-Crypt-Twofish>=2.14:${PORTSDIR}/security/p5-Crypt-Twofish \
+ p5-Crypt-Random>=1.25:${PORTSDIR}/security/p5-Crypt-Random \
+ p5-Data-UUID>=1.217:${PORTSDIR}/devel/p5-Data-UUID \
+ p5-File-Temp>=0:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-PWSafe3/distinfo b/security/p5-Crypt-PWSafe3/distinfo
new file mode 100644
index 000000000000..c4c4f7088ffa
--- /dev/null
+++ b/security/p5-Crypt-PWSafe3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-PWSafe3-1.21.tar.gz) = d2bd49387655db25f4aeb29cd27940d4a95c114e1ab3def57f83e98bf5ef2114
+SIZE (Crypt-PWSafe3-1.21.tar.gz) = 24886
diff --git a/security/p5-Crypt-PWSafe3/pkg-descr b/security/p5-Crypt-PWSafe3/pkg-descr
new file mode 100644
index 000000000000..6e62d8dde1de
--- /dev/null
+++ b/security/p5-Crypt-PWSafe3/pkg-descr
@@ -0,0 +1,3 @@
+Crypt::PWSafe3 provides read/write access to Password Safe V3 database files.
+
+WWW: http://search.cpan.org/dist/Crypt-PWSafe3/
diff --git a/security/p5-Crypt-PWSafe3/pkg-plist b/security/p5-Crypt-PWSafe3/pkg-plist
new file mode 100644
index 000000000000..440439394e18
--- /dev/null
+++ b/security/p5-Crypt-PWSafe3/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Crypt/PWSafe3.pm
+%%SITE_PERL%%/Crypt/PWSafe3/Databaseformat.pm
+%%SITE_PERL%%/Crypt/PWSafe3/Field.pm
+%%SITE_PERL%%/Crypt/PWSafe3/HeaderField.pm
+%%SITE_PERL%%/Crypt/PWSafe3/PasswordPolicy.pm
+%%SITE_PERL%%/Crypt/PWSafe3/Record.pm
+%%SITE_PERL%%/Crypt/PWSafe3/SHA256.pm
+%%PERL5_MAN3%%/Crypt::PWSafe3.3.gz
+%%PERL5_MAN3%%/Crypt::PWSafe3::Databaseformat.3.gz
+%%PERL5_MAN3%%/Crypt::PWSafe3::Field.3.gz
+%%PERL5_MAN3%%/Crypt::PWSafe3::HeaderField.3.gz
+%%PERL5_MAN3%%/Crypt::PWSafe3::PasswordPolicy.3.gz
+%%PERL5_MAN3%%/Crypt::PWSafe3::Record.3.gz
+%%PERL5_MAN3%%/Crypt::PWSafe3::SHA256.3.gz