aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-RC4
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-01-26 03:11:46 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-01-26 03:11:46 +0000
commit50c8478051873ff58eee3f0b04974b3761e2539d (patch)
treea958edd4ef1c41d2449ce7649c8e63a277f262eb /security/p5-Crypt-RC4
parent7b6c9b4ed1cd6795ab2e8e925698d831f2b7f7a1 (diff)
downloadports-50c8478051873ff58eee3f0b04974b3761e2539d.tar.gz
ports-50c8478051873ff58eee3f0b04974b3761e2539d.zip
Notes
Diffstat (limited to 'security/p5-Crypt-RC4')
-rw-r--r--security/p5-Crypt-RC4/Makefile22
-rw-r--r--security/p5-Crypt-RC4/distinfo1
-rw-r--r--security/p5-Crypt-RC4/pkg-comment1
-rw-r--r--security/p5-Crypt-RC4/pkg-descr18
-rw-r--r--security/p5-Crypt-RC4/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/security/p5-Crypt-RC4/Makefile b/security/p5-Crypt-RC4/Makefile
new file mode 100644
index 000000000000..ee9633f35774
--- /dev/null
+++ b/security/p5-Crypt-RC4/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Crypt::RC4
+# Date created: 30 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-RC4
+PORTVERSION= 2.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::RC4.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-RC4/distinfo b/security/p5-Crypt-RC4/distinfo
new file mode 100644
index 000000000000..8b08a9ec83aa
--- /dev/null
+++ b/security/p5-Crypt-RC4/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-RC4-2.02.tar.gz) = 4ca59a7e58ac9597c3b4f3f46ea22629
diff --git a/security/p5-Crypt-RC4/pkg-comment b/security/p5-Crypt-RC4/pkg-comment
new file mode 100644
index 000000000000..6388c484694c
--- /dev/null
+++ b/security/p5-Crypt-RC4/pkg-comment
@@ -0,0 +1 @@
+Perl implementation of the RC4 encryption algorithm
diff --git a/security/p5-Crypt-RC4/pkg-descr b/security/p5-Crypt-RC4/pkg-descr
new file mode 100644
index 000000000000..1a5e06cf096b
--- /dev/null
+++ b/security/p5-Crypt-RC4/pkg-descr
@@ -0,0 +1,18 @@
+A simple implementation of the RC4 algorithm, developed by RSA
+Security, Inc. Here is the description from RSA's website:
+
+RC4 is a stream cipher designed by Rivest for RSA Data Security
+(now RSA Security). It is a variable key-size stream cipher with
+byte-oriented operations. The algorithm is based on the use of a
+random permutation. Analysis shows that the period of the cipher
+is overwhelmingly likely to be greater than 10100. Eight to sixteen
+machine operations are required per output byte, and the cipher can
+be expected to run very quickly in software. Independent analysts
+have scrutinized the algorithm and it is considered secure.
+
+Based substantially on the "RC4 in 3 lines of perl" found at
+http://www.cypherspace.org
+
+WWW: http://search.cpan.org/search?dist=Crypt-RC4
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/security/p5-Crypt-RC4/pkg-plist b/security/p5-Crypt-RC4/pkg-plist
new file mode 100644
index 000000000000..709e992f69c5
--- /dev/null
+++ b/security/p5-Crypt-RC4/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/RC4.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/RC4/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/RC4
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Crypt 2>/dev/null || true