aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-RHash
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-08-22 12:50:05 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-08-22 12:50:05 +0000
commit0104243f3d730efd4bf6c4b74868c2939696b309 (patch)
treeeca856dbe302e63b7956eda0fc457ee3e9b52ace /security/p5-Crypt-RHash
parent27ec30364b0e99ab9ebc36903442f6a1e0a45ee7 (diff)
Notes
Diffstat (limited to 'security/p5-Crypt-RHash')
-rw-r--r--security/p5-Crypt-RHash/Makefile21
-rw-r--r--security/p5-Crypt-RHash/distinfo2
-rw-r--r--security/p5-Crypt-RHash/files/patch-librhash__rhash_torrent.h11
-rw-r--r--security/p5-Crypt-RHash/pkg-descr8
-rw-r--r--security/p5-Crypt-RHash/pkg-plist7
5 files changed, 49 insertions, 0 deletions
diff --git a/security/p5-Crypt-RHash/Makefile b/security/p5-Crypt-RHash/Makefile
new file mode 100644
index 000000000000..0c0e12ba3a66
--- /dev/null
+++ b/security/p5-Crypt-RHash/Makefile
@@ -0,0 +1,21 @@
+# Created by: perl@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= Crypt-RHash
+PORTVERSION= 0.91
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Compute hash sums and magnet links
+
+LICENSE= MIT
+
+USES= perl5
+USE_PERL5= configure fixpacklist
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/mach/auto/Crypt/Rhash/Rhash.so
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-RHash/distinfo b/security/p5-Crypt-RHash/distinfo
new file mode 100644
index 000000000000..25b8af2c0aac
--- /dev/null
+++ b/security/p5-Crypt-RHash/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-RHash-0.91.tar.gz) = ce615fb0214c83c3ee7484937c7c64410d33882f0c9287baafee43b8755e55bc
+SIZE (Crypt-RHash-0.91.tar.gz) = 153862
diff --git a/security/p5-Crypt-RHash/files/patch-librhash__rhash_torrent.h b/security/p5-Crypt-RHash/files/patch-librhash__rhash_torrent.h
new file mode 100644
index 000000000000..4f97af214516
--- /dev/null
+++ b/security/p5-Crypt-RHash/files/patch-librhash__rhash_torrent.h
@@ -0,0 +1,11 @@
+--- ./librhash/rhash_torrent.h.orig 2014-08-22 08:37:39.000000000 -0400
++++ ./librhash/rhash_torrent.h 2014-08-22 08:37:46.000000000 -0400
+@@ -11,8 +11,6 @@
+ # define RHASH_API
+ #endif
+
+-typedef struct rhash_context* rhash;
+-
+ /* a binary string with length */
+ typedef struct rhash_str
+ {
diff --git a/security/p5-Crypt-RHash/pkg-descr b/security/p5-Crypt-RHash/pkg-descr
new file mode 100644
index 000000000000..efe8f0c28749
--- /dev/null
+++ b/security/p5-Crypt-RHash/pkg-descr
@@ -0,0 +1,8 @@
+Crypt::Rhash module is an object-oriented interface to the LibRHash library,
+allowing simultaneous calculation of several hash functions for a file or a
+text message.
+
+Resulting hash digest can be obtained in hexadecimal, BASE32, BASE64, raw
+binary format or as a magnet link.
+
+WWW: http://search.cpan.org/dist/Crypt-RHash/
diff --git a/security/p5-Crypt-RHash/pkg-plist b/security/p5-Crypt-RHash/pkg-plist
new file mode 100644
index 000000000000..5aea5bd3afb4
--- /dev/null
+++ b/security/p5-Crypt-RHash/pkg-plist
@@ -0,0 +1,7 @@
+%%PERL5_MAN3%%/Crypt::Rhash.3.gz
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Rhash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Rhash/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Rhash/Rhash.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Rhash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt