aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-RSA
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2005-12-15 20:45:08 +0000
committerAaron Dalton <aaron@FreeBSD.org>2005-12-15 20:45:08 +0000
commite6722e8d1a81273e01f6d50bbfc83257a58222ed (patch)
tree1003184cf89e077eca29fa181fb01961ea22e603 /security/p5-Crypt-RSA
parent7dc64eb119866d6ba55e29c900dfcb46d7b63240 (diff)
downloadports-e6722e8d1a81273e01f6d50bbfc83257a58222ed.tar.gz
ports-e6722e8d1a81273e01f6d50bbfc83257a58222ed.zip
Notes
Diffstat (limited to 'security/p5-Crypt-RSA')
-rw-r--r--security/p5-Crypt-RSA/Makefile32
-rw-r--r--security/p5-Crypt-RSA/distinfo5
-rw-r--r--security/p5-Crypt-RSA/pkg-plist30
3 files changed, 42 insertions, 25 deletions
diff --git a/security/p5-Crypt-RSA/Makefile b/security/p5-Crypt-RSA/Makefile
index 137261e30fa8..daecf9cc48ba 100644
--- a/security/p5-Crypt-RSA/Makefile
+++ b/security/p5-Crypt-RSA/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Crypt-RSA
-PORTVERSION= 1.50
+PORTVERSION= 1.57
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Crypt
@@ -27,16 +27,30 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-
${SITE_PERL}/${PERL_ARCH}/Digest/MD2.pm:${PORTSDIR}/security/p5-Digest-MD2 \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/Tie/EncryptedHash.pm:${PORTSDIR}/security/p5-Tie-EncryptedHash \
- ${SITE_PERL}/MD5.pm:${PORTSDIR}/security/p5-MD5
+ ${SITE_PERL}/${PERL_ARCH}/Math/Pari.pm:${PORTSDIR}/math/p5-Math-Pari
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= Crypt::RSA::Key.3 Crypt::RSA::SS::PSS.3 \
- Crypt::RSA::Primitives.3 Crypt::RSA::ES::OAEP.3 \
- Crypt::RSA.3 Crypt::RSA::SS::PKCS1v15.3 \
- Crypt::RSA::DataFormat.3 Crypt::RSA::Key::Private.3 \
- Crypt::RSA::ES::PKCS1v15.3 Crypt::RSA::Debug.3 \
- Crypt::RSA::Key::Public.3 Crypt::RSA::Errorhandler.3
+MAN3= Crypt::RSA.3 \
+ Crypt::RSA::DataFormat.3 \
+ Crypt::RSA::Debug.3 \
+ Crypt::RSA::ES::OAEP.3 \
+ Crypt::RSA::ES::PKCS1v15.3 \
+ Crypt::RSA::Errorhandler.3 \
+ Crypt::RSA::Key.3 \
+ Crypt::RSA::Key::Private.3 \
+ Crypt::RSA::Key::Private::SSH.3 \
+ Crypt::RSA::Key::Public.3 \
+ Crypt::RSA::Key::Public::SSH.3 \
+ Crypt::RSA::Primitives.3 \
+ Crypt::RSA::SS::PKCS1v15.3 \
+ Crypt::RSA::SS::PSS.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or above due to dependencies
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-RSA/distinfo b/security/p5-Crypt-RSA/distinfo
index d2f53c104bb4..f6d783018098 100644
--- a/security/p5-Crypt-RSA/distinfo
+++ b/security/p5-Crypt-RSA/distinfo
@@ -1,2 +1,3 @@
-MD5 (Crypt-RSA-1.50.tar.gz) = 422ee7bbb5b31b146c4fd8c5993af988
-SIZE (Crypt-RSA-1.50.tar.gz) = 32763
+MD5 (Crypt-RSA-1.57.tar.gz) = 3fd02d3d9e398e26848a0d49bd3b8ccd
+SHA256 (Crypt-RSA-1.57.tar.gz) = ece1d64b8a4568132cdea3369eb039e3bdedb40aa5838c385d0fbf83f3c61be7
+SIZE (Crypt-RSA-1.57.tar.gz) = 34579
diff --git a/security/p5-Crypt-RSA/pkg-plist b/security/p5-Crypt-RSA/pkg-plist
index 7eb7882cc609..9b949c687f52 100644
--- a/security/p5-Crypt-RSA/pkg-plist
+++ b/security/p5-Crypt-RSA/pkg-plist
@@ -1,22 +1,24 @@
-%%SITE_PERL%%/Crypt/RSA/Key.pm
-%%SITE_PERL%%/Crypt/RSA/SS/PSS.pm
-%%SITE_PERL%%/Crypt/RSA/SS/PKCS1v15.pm
+%%SITE_PERL%%/Crypt/RSA.pm
+%%SITE_PERL%%/Crypt/RSA/DataFormat.pm
+%%SITE_PERL%%/Crypt/RSA/Debug.pm
%%SITE_PERL%%/Crypt/RSA/ES/OAEP.pm
%%SITE_PERL%%/Crypt/RSA/ES/PKCS1v15.pm
-%%SITE_PERL%%/Crypt/RSA/Primitives.pm
-%%SITE_PERL%%/Crypt/RSA/Key/Private/SSH.pm
+%%SITE_PERL%%/Crypt/RSA/Errorhandler.pm
+%%SITE_PERL%%/Crypt/RSA/Key.pm
%%SITE_PERL%%/Crypt/RSA/Key/Private.pm
-%%SITE_PERL%%/Crypt/RSA/Key/Public/SSH.pm
+%%SITE_PERL%%/Crypt/RSA/Key/Private/SSH.pm
%%SITE_PERL%%/Crypt/RSA/Key/Public.pm
-%%SITE_PERL%%/Crypt/RSA/DataFormat.pm
-%%SITE_PERL%%/Crypt/RSA/Debug.pm
-%%SITE_PERL%%/Crypt/RSA/Errorhandler.pm
-%%SITE_PERL%%/Crypt/RSA.pm
+%%SITE_PERL%%/Crypt/RSA/Key/Public/SSH.pm
+%%SITE_PERL%%/Crypt/RSA/Primitives.pm
+%%SITE_PERL%%/Crypt/RSA/SS/PKCS1v15.pm
+%%SITE_PERL%%/Crypt/RSA/SS/PSS.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/RSA/.packlist
-@dirrm %%SITE_PERL%%/Crypt/RSA/ES
-@dirrm %%SITE_PERL%%/Crypt/RSA/Key/Private
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/RSA
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Crypt/RSA/SS
@dirrm %%SITE_PERL%%/Crypt/RSA/Key/Public
+@dirrm %%SITE_PERL%%/Crypt/RSA/Key/Private
@dirrm %%SITE_PERL%%/Crypt/RSA/Key
-@dirrm %%SITE_PERL%%/Crypt/RSA/SS
+@dirrm %%SITE_PERL%%/Crypt/RSA/ES
@dirrm %%SITE_PERL%%/Crypt/RSA
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/RSA
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true