aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Rabbit
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-03-31 20:33:58 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-03-31 20:33:58 +0000
commitc5fb2bb5569face0b9e8dd08993295fbc44c660a (patch)
treee967594121176f847548a780938793adf0e028e2 /security/p5-Crypt-Rabbit
parent62a32f108169b463244dbde90bc50a10b18e45f4 (diff)
- Remove support for old Perl from my ports
Notes
Notes: svn path=/head/; revision=188903
Diffstat (limited to 'security/p5-Crypt-Rabbit')
-rw-r--r--security/p5-Crypt-Rabbit/Makefile14
-rw-r--r--security/p5-Crypt-Rabbit/files/extrapatch-Rabbit.xs18
2 files changed, 1 insertions, 31 deletions
diff --git a/security/p5-Crypt-Rabbit/Makefile b/security/p5-Crypt-Rabbit/Makefile
index e6d74384f650..4cdc3c8986e0 100644
--- a/security/p5-Crypt-Rabbit/Makefile
+++ b/security/p5-Crypt-Rabbit/Makefile
@@ -17,16 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Rabbit.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
-RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
-EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Rabbit.xs
-
-post-patch:
- ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Rabbit.pm
- ${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Rabbit.pm ${WRKSRC}/t/*.t
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Rabbit/files/extrapatch-Rabbit.xs b/security/p5-Crypt-Rabbit/files/extrapatch-Rabbit.xs
deleted file mode 100644
index ccff81e7ae2f..000000000000
--- a/security/p5-Crypt-Rabbit/files/extrapatch-Rabbit.xs
+++ /dev/null
@@ -1,18 +0,0 @@
---- Rabbit.xs.orig Sat Dec 31 03:49:51 2005
-+++ Rabbit.xs Sat Dec 31 03:50:13 2005
-@@ -4,6 +4,15 @@
- #include "ppport.h"
- #include "_rabbit.c"
-
-+/* try to be compatible with older perls */
-+/* SvPV_nolen() macro first defined in 5.005_55 */
-+/* this is slow, not threadsafe, but works */
-+#include "patchlevel.h"
-+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
-+static STRLEN nolen_na;
-+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
-+#endif
-+
- typedef struct rabbit {
- t_instance state;
- }* Crypt__Rabbit;