aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Random
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-09-12 00:45:21 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-09-12 00:45:21 +0000
commit8ca909d45cdffb833f8c96f1128197fbe4e51b80 (patch)
treeb47a4be4d26934028a3ab50077f5cbf5cfc2f5e9 /security/p5-Crypt-Random
parentcfdff71114e100428878ff6d6e779919650ebd0e (diff)
downloadports-8ca909d45cdffb833f8c96f1128197fbe4e51b80.tar.gz
ports-8ca909d45cdffb833f8c96f1128197fbe4e51b80.zip
Notes
Diffstat (limited to 'security/p5-Crypt-Random')
-rw-r--r--security/p5-Crypt-Random/Makefile29
-rw-r--r--security/p5-Crypt-Random/distinfo1
-rw-r--r--security/p5-Crypt-Random/pkg-comment1
-rw-r--r--security/p5-Crypt-Random/pkg-descr15
-rw-r--r--security/p5-Crypt-Random/pkg-plist12
5 files changed, 58 insertions, 0 deletions
diff --git a/security/p5-Crypt-Random/Makefile b/security/p5-Crypt-Random/Makefile
new file mode 100644
index 000000000000..596e21e3965f
--- /dev/null
+++ b/security/p5-Crypt-Random/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Crypt-Random
+# Date created: Tue Sep 11 10:47:19 PDT 2001
+# Whom: Michael Haro <mharo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Random
+PORTVERSION= 1.11
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mharo@FreeBSD.org
+
+PERLBASE= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+BUILD_DEPENDS= ${PERLBASE}/${PERL_ARCH}/Math/Pari.pm:${PORTSDIR}/math/p5-Math-Pari \
+ ${PERLBASE}/Class/Loader.pm:${PORTSDIR}/devel/p5-Class-Loader
+
+RESTRICTED= "Crypto; export-controlled"
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::Random.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Random/distinfo b/security/p5-Crypt-Random/distinfo
new file mode 100644
index 000000000000..960f01f16954
--- /dev/null
+++ b/security/p5-Crypt-Random/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-Random-1.11.tar.gz) = a2bfc1a6a4c2e03838d96c1bafd4cd9a
diff --git a/security/p5-Crypt-Random/pkg-comment b/security/p5-Crypt-Random/pkg-comment
new file mode 100644
index 000000000000..05a2b47d8715
--- /dev/null
+++ b/security/p5-Crypt-Random/pkg-comment
@@ -0,0 +1 @@
+Cryptographically Secure, True Random Number Generator
diff --git a/security/p5-Crypt-Random/pkg-descr b/security/p5-Crypt-Random/pkg-descr
new file mode 100644
index 000000000000..fa82f59dc5c9
--- /dev/null
+++ b/security/p5-Crypt-Random/pkg-descr
@@ -0,0 +1,15 @@
+Crypt::Random is an interface module to the /dev/random device found on most
+modern Unix systems. The /dev/random driver gathers environmental noise from
+various non-deterministic sources including inter-keyboard timings and
+inter-interrupt timings that occur within the operating system environment.
+
+The /dev/random driver maintains an estimate of true randomness in the pool and
+decreases it every time random strings are requested for use. When the estimate
+goes down to zero, the routine blocks and waits for the occurrence of
+non-deterministic events to refresh the pool.
+
+The /dev/random kernel module also provides another interface, /dev/urandom,
+that does not wait for the entropy-pool to recharge and returns as many bytes
+as requested. /dev/urandom is considerably faster at generation compared to
+/dev/random, which should be used only when very high quality randomness is
+desired.
diff --git a/security/p5-Crypt-Random/pkg-plist b/security/p5-Crypt-Random/pkg-plist
new file mode 100644
index 000000000000..291798b98ea0
--- /dev/null
+++ b/security/p5-Crypt-Random/pkg-plist
@@ -0,0 +1,12 @@
+bin/makerandom
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/Random/Provider/rand.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/Random/Provider/devurandom.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/Random/Provider/egd.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/Random/Provider/devrandom.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/Random/Provider/File.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/Random/Generator.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/Random.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Random/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Crypt/Random/Provider
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Crypt/Random
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Random