aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-SSLeay
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-08-07 04:14:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-08-07 04:14:43 +0000
commitede3b7e8061e45f2ec1abd92047925d26ac70635 (patch)
tree5cb6102954a46900688b721fe2428d6a74b8f504 /security/p5-Crypt-SSLeay
parent432e73fb58dec75c138c9e2a79c9775d6377c138 (diff)
downloadports-ede3b7e8061e45f2ec1abd92047925d26ac70635.tar.gz
ports-ede3b7e8061e45f2ec1abd92047925d26ac70635.zip
Notes
Diffstat (limited to 'security/p5-Crypt-SSLeay')
-rw-r--r--security/p5-Crypt-SSLeay/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/p5-Crypt-SSLeay/Makefile b/security/p5-Crypt-SSLeay/Makefile
index 14d7d1c2402d..f8f5fefcbfbb 100644
--- a/security/p5-Crypt-SSLeay/Makefile
+++ b/security/p5-Crypt-SSLeay/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= p5-LWP-Protocol-https>=6.02:${PORTSDIR}/www/p5-LWP-Protocol-https
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Try-Tiny>=0.09:${PORTSDIR}/lang/p5-Try-Tiny
-CONFIGURE_ARGS= --lib=${OPENSSLBASE} --no-live-tests
+CONFIGURE_ENV= CRYPT_SSLEAY_LIVE_TEST_WANTED=0
MAKE_ARGS= PASTHRU_INC=-I${OPENSSLINC}
PERL_CONFIGURE= yes
USE_OPENSSL= yes
@@ -33,4 +33,8 @@ MAN3= Crypt::SSLeay.3 Net::SSL.3
TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/LIBS/ s|-lssl32 -lssleay32 -leay32|-L${OPENSSLLIB}|' \
+ -e '/is_live_test_wanted()/d' ${WRKSRC}/Makefile.PL
+
.include <bsd.port.post.mk>