aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-xDBM_File
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-01-03 09:21:41 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-01-03 09:21:41 +0000
commit823e492c81ab86543c57ebf5eae7a35ea25163f5 (patch)
treecd534d5a19ca231c2fb6d839a86cd8cb6abe0a94 /security/p5-Crypt-xDBM_File
parent57fecf181c346ce9248732016430d952b9188498 (diff)
downloadports-823e492c81ab86543c57ebf5eae7a35ea25163f5.tar.gz
ports-823e492c81ab86543c57ebf5eae7a35ea25163f5.zip
Notes
Diffstat (limited to 'security/p5-Crypt-xDBM_File')
-rw-r--r--security/p5-Crypt-xDBM_File/Makefile31
-rw-r--r--security/p5-Crypt-xDBM_File/distinfo1
-rw-r--r--security/p5-Crypt-xDBM_File/pkg-descr18
-rw-r--r--security/p5-Crypt-xDBM_File/pkg-plist5
4 files changed, 55 insertions, 0 deletions
diff --git a/security/p5-Crypt-xDBM_File/Makefile b/security/p5-Crypt-xDBM_File/Makefile
new file mode 100644
index 000000000000..1316d747adee
--- /dev/null
+++ b/security/p5-Crypt-xDBM_File/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Crypt-xDBM_File
+# Date created: Tue Dec 30 08:56:41 CST 2003
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-xDBM_File
+PORTVERSION= 1.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Perl module encrypt almost any kind of dbm file
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::xDBM_File.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-xDBM_File/distinfo b/security/p5-Crypt-xDBM_File/distinfo
new file mode 100644
index 000000000000..c7c34f6fda59
--- /dev/null
+++ b/security/p5-Crypt-xDBM_File/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-xDBM_File-1.01.tar.gz) = 4e1c91ebbf896ae094c7b150e4c67883
diff --git a/security/p5-Crypt-xDBM_File/pkg-descr b/security/p5-Crypt-xDBM_File/pkg-descr
new file mode 100644
index 000000000000..c289f6eeafe1
--- /dev/null
+++ b/security/p5-Crypt-xDBM_File/pkg-descr
@@ -0,0 +1,18 @@
+Crypt::xDBM_File encrypts/decrypts the data in a gdbm,ndbm,sdbm (and
+maybe even berkeleyDB, but I didn't test that) file. It gets tied to a
+hash and you just access the hash like normal. The crypt function can
+be any of the CPAN modules that use encrypt, decrypt, keysize, blocksize
+(so Crypt::IDEA, Crypt::DES, Crypt::Blowfish, ... should all work)
+
+***IMPORTANT*** Encryption keys (the key you pass in on the tie line)
+will be padded or truncated to fit the keysize(). Data (the key/values of
+the hash) is padded to fill complete blocks of blocksize().
+
+The padding is stripped before being returned to the user so you shouldn't
+need to worry about it (except truncated keys). Read the doc that comes
+with crypt function to get an idea of what these sizes are. If keysize
+or blocksize returns a zero the default is set to 8 bytes (64 bits).
+
+WWW: http://search.cpan.org/~eestabroo/Crypt-xDBM_File/
+
+Author: Eric Estabrooks <eric@urbanrage.com>
diff --git a/security/p5-Crypt-xDBM_File/pkg-plist b/security/p5-Crypt-xDBM_File/pkg-plist
new file mode 100644
index 000000000000..441165e81111
--- /dev/null
+++ b/security/p5-Crypt-xDBM_File/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/xDBM_File.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/xDBM_File/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/xDBM_File
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true