aboutsummaryrefslogtreecommitdiff
path: root/security/p5-CryptX
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-05-25 03:04:17 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-05-25 03:04:17 +0000
commit8056067f910cd6c9b5eb380af4a66550759bdc3d (patch)
tree81ae84330d206d3eeb60db85810ab149e86459cc /security/p5-CryptX
parent2d7476a2fa5dac58f64fb83b77b438c56dbec9f2 (diff)
downloadports-8056067f910cd6c9b5eb380af4a66550759bdc3d.tar.gz
ports-8056067f910cd6c9b5eb380af4a66550759bdc3d.zip
Upgrade to 0.022.
Notes
Notes: svn path=/head/; revision=387367
Diffstat (limited to 'security/p5-CryptX')
-rw-r--r--security/p5-CryptX/Makefile3
-rw-r--r--security/p5-CryptX/distinfo4
-rw-r--r--security/p5-CryptX/files/patch-src__ltc__headerss__tomcrypt_macros.h107
-rw-r--r--security/p5-CryptX/pkg-plist4
4 files changed, 7 insertions, 111 deletions
diff --git a/security/p5-CryptX/Makefile b/security/p5-CryptX/Makefile
index 8316f2c66001..00ef65f932da 100644
--- a/security/p5-CryptX/Makefile
+++ b/security/p5-CryptX/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= CryptX
-PORTVERSION= 0.021
-PORTREVISION= 1
+PORTVERSION= 0.022
CATEGORIES= security perl5
MASTER_SITES= CPAN/Crypt
PKGNAMEPREFIX= p5-
diff --git a/security/p5-CryptX/distinfo b/security/p5-CryptX/distinfo
index 06ec527cd2bb..e13bebabee39 100644
--- a/security/p5-CryptX/distinfo
+++ b/security/p5-CryptX/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CryptX-0.021.tar.gz) = 155bf8ff158e8e8e252c16ff16655d1ec22866e56b10dea5e419e77e53d1b2f7
-SIZE (CryptX-0.021.tar.gz) = 1230263
+SHA256 (CryptX-0.022.tar.gz) = 2a128a9f942fef2f4081c4123ae97a0f7be7649ca0e1347941ca2ed5b8102044
+SIZE (CryptX-0.022.tar.gz) = 1323981
diff --git a/security/p5-CryptX/files/patch-src__ltc__headerss__tomcrypt_macros.h b/security/p5-CryptX/files/patch-src__ltc__headerss__tomcrypt_macros.h
deleted file mode 100644
index 42fd8ea4a9f7..000000000000
--- a/security/p5-CryptX/files/patch-src__ltc__headerss__tomcrypt_macros.h
+++ /dev/null
@@ -1,107 +0,0 @@
---- src/ltc/headers/tomcrypt_macros.h.orig 2014-01-23 16:45:59.000000000 +0100
-+++ src/ltc/headers/tomcrypt_macros.h 2015-03-02 20:23:48.396007000 +0100
-@@ -281,21 +281,19 @@
-
- #ifndef LTC_NO_ROLC
-
--static inline ulong32 ROLc(ulong32 word, const int i)
--{
-- asm ("roll %2,%0"
-- :"=r" (word)
-- :"0" (word),"I" (i));
-- return word;
--}
--
--static inline ulong32 RORc(ulong32 word, const int i)
--{
-- asm ("rorl %2,%0"
-- :"=r" (word)
-- :"0" (word),"I" (i));
-- return word;
--}
-+#define ROLc(word, i) ({ \
-+ ulong32 _word = word; \
-+ asm ("roll %2,%0" \
-+ :"=r" (_word) \
-+ :"0" (_word),"I" (i)); \
-+ _word; })
-+
-+#define RORc(word, i) ({ \
-+ ulong32 _word = word; \
-+ asm ("rorl %2,%0" \
-+ :"=r" (_word) \
-+ :"0" (_word),"I" (i)); \
-+ _word; })
-
- #else
-
-@@ -324,21 +322,19 @@
-
- #ifndef LTC_NO_ROLC
-
--static inline ulong32 ROLc(ulong32 word, const int i)
--{
-- asm ("rotlwi %0,%0,%2"
-- :"=r" (word)
-- :"0" (word),"I" (i));
-- return word;
--}
--
--static inline ulong32 RORc(ulong32 word, const int i)
--{
-- asm ("rotrwi %0,%0,%2"
-- :"=r" (word)
-- :"0" (word),"I" (i));
-- return word;
--}
-+#define ROLc(word, i) ({ \
-+ ulong32 _word = word; \
-+ asm ("rotlwi %0,%0,%2" \
-+ :"=r" (_word) \
-+ :"0" (_word),"I" (i)); \
-+ _word; })
-+
-+#define RORc(word, i) ({ \
-+ ulong32 _word = word; \
-+ asm ("rotrwi %0,%0,%2" \
-+ :"=r" (_word) \
-+ :"0" (_word),"I" (i)); \
-+ _word; })
-
- #else
-
-@@ -380,21 +376,19 @@
-
- #ifndef LTC_NO_ROLC
-
--static inline ulong64 ROL64c(ulong64 word, const int i)
--{
-- asm("rolq %2,%0"
-- :"=r" (word)
-- :"0" (word),"J" (i));
-- return word;
--}
--
--static inline ulong64 ROR64c(ulong64 word, const int i)
--{
-- asm("rorq %2,%0"
-- :"=r" (word)
-- :"0" (word),"J" (i));
-- return word;
--}
-+#define ROL64c(word, i) ({ \
-+ ulong64 _word = word; \
-+ asm ("rolq %2,%0" \
-+ :"=r" (_word) \
-+ :"0" (_word),"J" (i)); \
-+ _word; })
-+
-+#define ROR64c(word, i) ({ \
-+ ulong64 _word = word; \
-+ asm ("rorq %2,%0" \
-+ :"=r" (_word) \
-+ :"0" (_word),"J" (i)); \
-+ _word; })
-
- #else /* LTC_NO_ROLC */
-
diff --git a/security/p5-CryptX/pkg-plist b/security/p5-CryptX/pkg-plist
index c6893afeaec1..cea6b79048f3 100644
--- a/security/p5-CryptX/pkg-plist
+++ b/security/p5-CryptX/pkg-plist
@@ -41,6 +41,8 @@
%%PERL5_MAN3%%/Crypt::Digest::SHA256.3.gz
%%PERL5_MAN3%%/Crypt::Digest::SHA384.3.gz
%%PERL5_MAN3%%/Crypt::Digest::SHA512.3.gz
+%%PERL5_MAN3%%/Crypt::Digest::SHA512_224.3.gz
+%%PERL5_MAN3%%/Crypt::Digest::SHA512_256.3.gz
%%PERL5_MAN3%%/Crypt::Digest::Tiger192.3.gz
%%PERL5_MAN3%%/Crypt::Digest::Whirlpool.3.gz
%%PERL5_MAN3%%/Crypt::KeyDerivation.3.gz
@@ -111,6 +113,8 @@
%%SITE_ARCH%%/Crypt/Digest/SHA256.pm
%%SITE_ARCH%%/Crypt/Digest/SHA384.pm
%%SITE_ARCH%%/Crypt/Digest/SHA512.pm
+%%SITE_ARCH%%/Crypt/Digest/SHA512_224.pm
+%%SITE_ARCH%%/Crypt/Digest/SHA512_256.pm
%%SITE_ARCH%%/Crypt/Digest/Tiger192.pm
%%SITE_ARCH%%/Crypt/Digest/Whirlpool.pm
%%SITE_ARCH%%/Crypt/KeyDerivation.pm