aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-01-23 15:12:54 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-01-23 15:12:54 +0000
commit4cad3b8780d34e8e4ff56e81110ddbe44e3dfd08 (patch)
treeb6f6992fd73d27df753c2704846fd4fc7ff6a977 /security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC
parentc4c223d69e8d8103dfc3a24fa9bfa66801d5dd98 (diff)
downloadports-4cad3b8780d34e8e4ff56e81110ddbe44e3dfd08.tar.gz
ports-4cad3b8780d34e8e4ff56e81110ddbe44e3dfd08.zip
Notes
Diffstat (limited to 'security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC')
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/Makefile28
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/distinfo2
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/pkg-descr7
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/pkg-plist4
4 files changed, 41 insertions, 0 deletions
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/Makefile b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/Makefile
new file mode 100644
index 000000000000..9a6866b425b0
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/Makefile
@@ -0,0 +1,28 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Dancer2-Plugin-Auth-Extensible-Provider-DBIC
+PORTVERSION= 0.501
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= Extensible authentication framework for Dancer2 apps using DBIC
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-DBIx-Class>=0:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-Dancer2-Plugin-Auth-Extensible>=0.501:${PORTSDIR}/security/p5-Dancer2-Plugin-Auth-Extensible \
+ p5-Dancer2-Plugin-DBIC>=0:${PORTSDIR}/databases/p5-Dancer2-Plugin-DBIC \
+ p5-String-CamelCase>=0:${PORTSDIR}/textproc/p5-String-CamelCase
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Class-Load>=0:${PORTSDIR}/devel/p5-Class-Load \
+ p5-DateTime-Format-SQLite>=0:${PORTSDIR}/devel/p5-DateTime-Format-SQLite \
+ p5-Path-Tiny>=0:${PORTSDIR}/devel/p5-Path-Tiny
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/distinfo b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/distinfo
new file mode 100644
index 000000000000..413961b145ec
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer2-Plugin-Auth-Extensible-Provider-DBIC-0.501.tar.gz) = 146c480f170c46f5bafed85047d01a9f2af9218d5a8569e4370722418611c4b0
+SIZE (Dancer2-Plugin-Auth-Extensible-Provider-DBIC-0.501.tar.gz) = 9874
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/pkg-descr b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/pkg-descr
new file mode 100644
index 000000000000..35418b04dd25
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/pkg-descr
@@ -0,0 +1,7 @@
+This class is an authentication provider designed to authenticate users
+against a database, using Dancer2::Plugin::DBIC to access a database.
+
+See Dancer2::Plugin::Auth::Extensible for details on how to use
+the authentication framework.
+
+WWW: http://search.cpan.org/dist/Dancer2-Plugin-Auth-Extensible-Provider-DBIC/
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/pkg-plist b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/pkg-plist
new file mode 100644
index 000000000000..8ab45d0c0da7
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-DBIC/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Dancer2/Plugin/Auth/Extensible/Provider/DBIC.pm
+%%SITE_PERL%%/Dancer2/Plugin/Auth/Extensible/Provider/README.pod
+%%PERL5_MAN3%%/Dancer2::Plugin::Auth::Extensible::Provider::DBIC.3.gz
+%%PERL5_MAN3%%/Dancer2::Plugin::Auth::Extensible::Provider::README.3.gz