aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Digest-Bcrypt
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-09-05 12:28:02 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-09-05 12:28:02 +0000
commite80e4713fb410ca3efbbeef75a6b07b4b7561e30 (patch)
treeb8770db76b2bfc3fb8d2591e281cfb805891dca4 /security/p5-Digest-Bcrypt
parent6393831e4daa89a07ed73ecced826787cc53a4c8 (diff)
downloadports-e80e4713fb410ca3efbbeef75a6b07b4b7561e30.tar.gz
ports-e80e4713fb410ca3efbbeef75a6b07b4b7561e30.zip
Notes
Diffstat (limited to 'security/p5-Digest-Bcrypt')
-rw-r--r--security/p5-Digest-Bcrypt/Makefile22
-rw-r--r--security/p5-Digest-Bcrypt/distinfo2
-rw-r--r--security/p5-Digest-Bcrypt/pkg-descr8
-rw-r--r--security/p5-Digest-Bcrypt/pkg-plist5
4 files changed, 37 insertions, 0 deletions
diff --git a/security/p5-Digest-Bcrypt/Makefile b/security/p5-Digest-Bcrypt/Makefile
new file mode 100644
index 000000000000..c6abcdada1d7
--- /dev/null
+++ b/security/p5-Digest-Bcrypt/Makefile
@@ -0,0 +1,22 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Digest-Bcrypt
+PORTVERSION= 1.0.1
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl interface to the bcrypt digest algorithm
+
+LICENSE= ART10
+
+BUILD_DEPENDS= p5-Crypt-Eksblowfish>0:${PORTSDIR}/security/p5-Crypt-Eksblowfish
+RUN_DEPENDS= p5-Crypt-Eksblowfish>0:${PORTSDIR}/security/p5-Crypt-Eksblowfish
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::Bcrypt.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Digest-Bcrypt/distinfo b/security/p5-Digest-Bcrypt/distinfo
new file mode 100644
index 000000000000..b863da06c30c
--- /dev/null
+++ b/security/p5-Digest-Bcrypt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Digest-Bcrypt-1.0.1.tar.gz) = 8326990624f1da453ce057e2cc1883f1d2a1d65639b98ddd533987b493c786e1
+SIZE (Digest-Bcrypt-1.0.1.tar.gz) = 11831
diff --git a/security/p5-Digest-Bcrypt/pkg-descr b/security/p5-Digest-Bcrypt/pkg-descr
new file mode 100644
index 000000000000..9f0e3640beb7
--- /dev/null
+++ b/security/p5-Digest-Bcrypt/pkg-descr
@@ -0,0 +1,8 @@
+Provides an interface to the bcrypt digest algorithm.
+
+This module subclasses Digest::base and can be used either directly or
+through the Digest meta-module. Using the latter is recommended.
+
+It is mostly a wrapper around Crypt::Eksblowfish::Bcrypt.
+
+WWW: https://metacpan.org/module/Digest::Bcrypt
diff --git a/security/p5-Digest-Bcrypt/pkg-plist b/security/p5-Digest-Bcrypt/pkg-plist
new file mode 100644
index 000000000000..f29d5de90701
--- /dev/null
+++ b/security/p5-Digest-Bcrypt/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Digest/Bcrypt.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Bcrypt/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Bcrypt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest
+@dirrmtry %%SITE_PERL%%/Digest