aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Digest-EMAC
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-17 16:00:52 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-17 16:00:52 +0000
commita9fd566668badebe30eb598913b2e1dcdce11f21 (patch)
treefc8a46169d426cc2eefa45c1ea4c7fe96b5611f1 /security/p5-Digest-EMAC
parent16c8614c5494036a2ecff931cd8179bdb19208c2 (diff)
downloadports-a9fd566668badebe30eb598913b2e1dcdce11f21.tar.gz
ports-a9fd566668badebe30eb598913b2e1dcdce11f21.zip
Notes
Diffstat (limited to 'security/p5-Digest-EMAC')
-rw-r--r--security/p5-Digest-EMAC/Makefile27
-rw-r--r--security/p5-Digest-EMAC/distinfo3
-rw-r--r--security/p5-Digest-EMAC/pkg-descr23
-rw-r--r--security/p5-Digest-EMAC/pkg-plist5
4 files changed, 58 insertions, 0 deletions
diff --git a/security/p5-Digest-EMAC/Makefile b/security/p5-Digest-EMAC/Makefile
new file mode 100644
index 000000000000..3eb784cd963d
--- /dev/null
+++ b/security/p5-Digest-EMAC/Makefile
@@ -0,0 +1,27 @@
+# Ports collection Makefile for: p5-Digest-EMAC
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-EMAC
+PORTVERSION= 1.2
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl5 interface to EMAC Double Message-Digest Algorithms
+
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::EMAC.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-EMAC/distinfo b/security/p5-Digest-EMAC/distinfo
new file mode 100644
index 000000000000..f47139121df0
--- /dev/null
+++ b/security/p5-Digest-EMAC/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-EMAC-1.2.tar.gz) = b794a64554dc1ea9b3714e8d6825ffd6
+SHA256 (Digest-EMAC-1.2.tar.gz) = a10f468a6afc1f0ac3d65498b4cbb40df742374f96a391d326a3f971c06282dc
+SIZE (Digest-EMAC-1.2.tar.gz) = 10348
diff --git a/security/p5-Digest-EMAC/pkg-descr b/security/p5-Digest-EMAC/pkg-descr
new file mode 100644
index 000000000000..b968c595188c
--- /dev/null
+++ b/security/p5-Digest-EMAC/pkg-descr
@@ -0,0 +1,23 @@
+This is Encrypted MAC (EMAC), formerly known as Double MAC (DMAC).
+Unlike HMAC, which reuses an existing one-way hash function, such as
+MD5, SHA-1 or RIPEMD-160, EMAC reuses an existing block cipher to
+produce a secure message authentication code (MAC).
+
+Using the block cipher, a message is encrypted in CBC mode. The last
+block is taken as the MAC of the message. For fixed-length messages,
+this method is provably secure. In reality, however, messages have
+arbitrary lengths, and this method is not secure. To make secure MACs
+for variable length messages, the last block is encrypted once again
+with a different key. The security of this construction has been proved
+in the paper, ``CBC MAC for Real-Time Data Sources'' by Erez Petrank
+and Charles Rackoff. The security can be proved on the assumption that
+the underlying block cipher is pseudo-random.
+
+The performance and key-agility of EMAC are reasonable. EMAC is
+preferable for short messages because the block length is smaller
+compared to the schemes based on a hash function. EMAC is also chosen
+as one of the NESSIE winners for Message Authentication Codes, along
+with UMAC, TTMAC and HMAC. The current NESSIE specification chooses the
+AES as block cipher.
+
+WWW: http://search.cpan.org/dist/Digest-EMAC
diff --git a/security/p5-Digest-EMAC/pkg-plist b/security/p5-Digest-EMAC/pkg-plist
new file mode 100644
index 000000000000..0822434bdb9f
--- /dev/null
+++ b/security/p5-Digest-EMAC/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Digest/EMAC.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/EMAC/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/EMAC/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Digest/ 2>/dev/null || true