aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Digest-HMAC
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-11 08:58:11 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-11 08:58:11 +0000
commita35a06a154c226fcecd7881bd8ad8bb77c00acae (patch)
treec336b2e578da829c67bb017ed05604ac636b20f8 /security/p5-Digest-HMAC
parente0a00e4b4619579f521f211fe8e49e242d114bbf (diff)
downloadports-a35a06a154c226fcecd7881bd8ad8bb77c00acae.tar.gz
ports-a35a06a154c226fcecd7881bd8ad8bb77c00acae.zip
Notes
Diffstat (limited to 'security/p5-Digest-HMAC')
-rw-r--r--security/p5-Digest-HMAC/Makefile28
-rw-r--r--security/p5-Digest-HMAC/distinfo1
-rw-r--r--security/p5-Digest-HMAC/pkg-comment1
-rw-r--r--security/p5-Digest-HMAC/pkg-descr20
-rw-r--r--security/p5-Digest-HMAC/pkg-plist6
5 files changed, 56 insertions, 0 deletions
diff --git a/security/p5-Digest-HMAC/Makefile b/security/p5-Digest-HMAC/Makefile
new file mode 100644
index 000000000000..b56aafca2a63
--- /dev/null
+++ b/security/p5-Digest-HMAC/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Digest-HMAC
+# Date created: 2001/12/11
+# Whom: nork@cityfujisawa.ne.jp
+#
+# $FreeBSD$
+#
+
+PORTNAME= Digest-HMAC
+PORTVERSION= 1.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nork@cityfujisawa.ne.jp
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Digest::HMAC.3 \
+ Digest::HMAC_MD5.3 \
+ Digest::HMAC_SHA1.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Digest-HMAC/distinfo b/security/p5-Digest-HMAC/distinfo
new file mode 100644
index 000000000000..657d04ae0fb3
--- /dev/null
+++ b/security/p5-Digest-HMAC/distinfo
@@ -0,0 +1 @@
+MD5 (Digest-HMAC-1.01.tar.gz) = 32dc54c765100c638b5d7f7ff4c5c626
diff --git a/security/p5-Digest-HMAC/pkg-comment b/security/p5-Digest-HMAC/pkg-comment
new file mode 100644
index 000000000000..501cc1d84ad5
--- /dev/null
+++ b/security/p5-Digest-HMAC/pkg-comment
@@ -0,0 +1 @@
+Perl5 interface to HMAC Message-Digest Algorithms
diff --git a/security/p5-Digest-HMAC/pkg-descr b/security/p5-Digest-HMAC/pkg-descr
new file mode 100644
index 000000000000..49befd3908a0
--- /dev/null
+++ b/security/p5-Digest-HMAC/pkg-descr
@@ -0,0 +1,20 @@
+Digest:: HMAC
+---------------------------------
+
+This package provide modules which calculate HMAC digests.
+
+To build the extensions, unpack this distribution somewhere, create
+the Makefile by running 'perl Makefile.PL' and do a 'make', 'make
+test', and if successful 'make install'.
+
+You will need perl version 5.004 or better to install these modules.
+Further documentation is embedded in the individual modules.
+
+Copyright 1998-1999 Gisle Aas.
+Copyright 1998 Graham Barr.
+Copyright 1997 Uwe Hollerbach.
+Copyright 1995-1996 Neil Winton.
+Copyright 1990-1992 RSA Data Security, Inc.
+
+This library is free software; you can redistribute it and/or
+modify it under the same terms as Perl itself.
diff --git a/security/p5-Digest-HMAC/pkg-plist b/security/p5-Digest-HMAC/pkg-plist
new file mode 100644
index 000000000000..de98ef9704f9
--- /dev/null
+++ b/security/p5-Digest-HMAC/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/Digest/HMAC.pm
+lib/perl5/site_perl/%%PERL_VER%%/Digest/HMAC_SHA1.pm
+lib/perl5/site_perl/%%PERL_VER%%/Digest/HMAC_MD5.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Digest/HMAC/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Digest
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Digest/HMAC