aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Digest-SHA
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-09-17 16:43:48 +0000
committerLars Thegler <lth@FreeBSD.org>2005-09-17 16:43:48 +0000
commit5f92c24a0b581bd26e26a85551e4b8a3cd0c0832 (patch)
tree11246ccc426763fa86eaba0267c2bee60877012d /security/p5-Digest-SHA
parent651c7e02180502e16b2e1a4412d6074f4155c41c (diff)
downloadports-5f92c24a0b581bd26e26a85551e4b8a3cd0c0832.tar.gz
ports-5f92c24a0b581bd26e26a85551e4b8a3cd0c0832.zip
Notes
Diffstat (limited to 'security/p5-Digest-SHA')
-rw-r--r--security/p5-Digest-SHA/Makefile26
-rw-r--r--security/p5-Digest-SHA/distinfo2
-rw-r--r--security/p5-Digest-SHA/pkg-descr9
-rw-r--r--security/p5-Digest-SHA/pkg-plist9
4 files changed, 46 insertions, 0 deletions
diff --git a/security/p5-Digest-SHA/Makefile b/security/p5-Digest-SHA/Makefile
new file mode 100644
index 000000000000..37da3cd1530f
--- /dev/null
+++ b/security/p5-Digest-SHA/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: p5-Digest-SHA
+# Date created: Aug 4, 2005
+# Whom: Travis Campbell <hcoyote@ghostar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Digest-SHA
+PORTVERSION= 5.31
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/M/MS/MSHELOR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hcoyote@ghostar.org
+COMMENT= Perl extension for SHA-1/224/256/384/512
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::SHA.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-SHA/distinfo b/security/p5-Digest-SHA/distinfo
new file mode 100644
index 000000000000..7967ee51cd16
--- /dev/null
+++ b/security/p5-Digest-SHA/distinfo
@@ -0,0 +1,2 @@
+MD5 (Digest-SHA-5.31.tar.gz) = 931cf9ac0ce1c93506de8e643585a9cb
+SIZE (Digest-SHA-5.31.tar.gz) = 45152
diff --git a/security/p5-Digest-SHA/pkg-descr b/security/p5-Digest-SHA/pkg-descr
new file mode 100644
index 000000000000..4453d5deaf5a
--- /dev/null
+++ b/security/p5-Digest-SHA/pkg-descr
@@ -0,0 +1,9 @@
+Digest::SHA is a complete implementation of the NIST Secure Hash
+Standard. It gives Perl programmers a convenient way to calculate
+SHA-1, SHA-224, SHA-256, SHA-384, and SHA-512 message digests. The
+module can handle all types of input, including partial-byte data.
+
+WWW: http://search.cpan.org/dist/Digest-SHA/
+
+- Travis Campbell
+hcoyote@ghostar.org
diff --git a/security/p5-Digest-SHA/pkg-plist b/security/p5-Digest-SHA/pkg-plist
new file mode 100644
index 000000000000..74333030a9b8
--- /dev/null
+++ b/security/p5-Digest-SHA/pkg-plist
@@ -0,0 +1,9 @@
+bin/shasum
+%%SITE_PERL%%/%%PERL_ARCH%%/Digest/SHA.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/SHA/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/SHA/SHA.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/SHA/SHA.so
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/SHA 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Digest/ 2>/dev/null || true