aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Digest-Whirlpool/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-17 11:21:52 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-17 11:21:52 +0000
commitbf5342d0cba88a2e4087afa4017102b20b2e2826 (patch)
treeea4d63c71b694117c0589f168cd245359435128f /security/p5-Digest-Whirlpool/Makefile
parent532ec61cb25c3966f95c65470541661e10aaef2c (diff)
Notes
Diffstat (limited to 'security/p5-Digest-Whirlpool/Makefile')
-rw-r--r--security/p5-Digest-Whirlpool/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/security/p5-Digest-Whirlpool/Makefile b/security/p5-Digest-Whirlpool/Makefile
new file mode 100644
index 000000000000..91bd99e637f2
--- /dev/null
+++ b/security/p5-Digest-Whirlpool/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-Whirlpool
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-Whirlpool
+PORTVERSION= 1.0.3
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for Whirlpool hash algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::Whirlpool.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>