aboutsummaryrefslogtreecommitdiff
path: root/security/p5-File-Scan/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2003-01-27 00:03:44 +0000
committerAnton Berezin <tobez@FreeBSD.org>2003-01-27 00:03:44 +0000
commit0ada4625ad3cb34ef299dfd4d703dc54b0eaeb84 (patch)
tree9116950e936280eebaba5a5a1546cb2cadca336a /security/p5-File-Scan/Makefile
parent28b6f273728457f2a061509290c41a6df39c8691 (diff)
Notes
Diffstat (limited to 'security/p5-File-Scan/Makefile')
-rw-r--r--security/p5-File-Scan/Makefile22
1 files changed, 21 insertions, 1 deletions
diff --git a/security/p5-File-Scan/Makefile b/security/p5-File-Scan/Makefile
index c2029b634c79..b9372a135287 100644
--- a/security/p5-File-Scan/Makefile
+++ b/security/p5-File-Scan/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= File-Scan
-PORTVERSION= 0.38
+PORTVERSION= 0.43
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= File/HDIAS
@@ -18,5 +18,25 @@ PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= File::Scan.3
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR} ${DOCSDIR}/docs
+.for file in Changes FAQ README TODO
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.for file in docs/write_sign_bin.txt
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}/docs
+.endfor
+.endif
+ @${MKDIR} ${EXAMPLESDIR} ${EXAMPLESDIR}/procmail
+.for file in latest.pl scan.pl
+ @${INSTALL_SCRIPT} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
+.endfor
+.for file in procmail/.procmailrc procmail/README procmail/scanvirus.pl
+ @${INSTALL_SCRIPT} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}/procmail
+.endfor
.include <bsd.port.mk>