aboutsummaryrefslogtreecommitdiff
path: root/security/p5-IO-Socket-SSL
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2012-06-05 14:31:57 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2012-06-05 14:31:57 +0000
commitfe28c145d26ff4f7fb24c402f0b169f9dd15792a (patch)
treeb6bb9f68a3891c635fca46634d98bbd7568d2c0d /security/p5-IO-Socket-SSL
parent5f4a456e719a61519010ce27a49eb90ba8250de7 (diff)
Notes
Diffstat (limited to 'security/p5-IO-Socket-SSL')
-rw-r--r--security/p5-IO-Socket-SSL/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/security/p5-IO-Socket-SSL/Makefile b/security/p5-IO-Socket-SSL/Makefile
index 1e891d283696..f453a3db3647 100644
--- a/security/p5-IO-Socket-SSL/Makefile
+++ b/security/p5-IO-Socket-SSL/Makefile
@@ -23,8 +23,9 @@ INSTALL_TARGET= pure_install
MAN3= IO::Socket::SSL.3
-OPTIONS= IDN "International Domain Names (IDN) support" off \
- IPV6 "IPv6 support" off
+OPTIONS_DEFINE= IDN IPV6
+IDN_DESC= International Domain Names (IDN) support
+IPV6_DESC= IPv6 support
.if !defined(NOPORTEXAMPLES)
PORTEXAMPLES= *
@@ -33,12 +34,14 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/example/* ${EXAMPLESDIR}
.endif
-.if defined(WITH_IDN)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MIDN}
RUN_DEPENDS+= p5-Net-LibIDN>=0:${PORTSDIR}/dns/p5-Net-LibIDN
.endif
-.if defined(WITH_IPV6)
-RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-Socket-INET6
+.if ${PORT_OPTIONS:MIPV6}
+RUN_DEPENDS+= p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6
.endif
regression-test: