aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Net-OpenID-JanRain
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-12-20 11:41:27 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-12-20 11:41:27 +0000
commitc91912f708c03bcdab26fc74c2b2443689d5f436 (patch)
tree1f7a2f7d45da4b222c09c98886eaa4cb81961f6e /security/p5-Net-OpenID-JanRain
parent6274ed3fd8f4ddbc9a42ec918c42e81da443421c (diff)
downloadports-c91912f708c03bcdab26fc74c2b2443689d5f436.tar.gz
ports-c91912f708c03bcdab26fc74c2b2443689d5f436.zip
Notes
Diffstat (limited to 'security/p5-Net-OpenID-JanRain')
-rw-r--r--security/p5-Net-OpenID-JanRain/Makefile42
-rw-r--r--security/p5-Net-OpenID-JanRain/distinfo3
-rw-r--r--security/p5-Net-OpenID-JanRain/pkg-descr14
-rw-r--r--security/p5-Net-OpenID-JanRain/pkg-plist23
4 files changed, 82 insertions, 0 deletions
diff --git a/security/p5-Net-OpenID-JanRain/Makefile b/security/p5-Net-OpenID-JanRain/Makefile
new file mode 100644
index 000000000000..4ffec5a99b38
--- /dev/null
+++ b/security/p5-Net-OpenID-JanRain/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-Net-OpenID-JanRain
+# Date created: 2006-12-19
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OpenID-JanRain
+PORTVERSION= 1.1.1
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= OpenID JanRain and Consumer with JanRain API
+
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/DH.pm:${PORTSDIR}/security/p5-Crypt-DH \
+ ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
+ ${SITE_PERL}/LWPx/ParanoidAgent.pm:${PORTSDIR}/www/p5-LWPx-ParanoidAgent \
+ ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt \
+ ${SITE_PERL}/Net/Yadis.pm:${PORTSDIR}/net/p5-Net-Yadis \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OpenID::JanRain::Consumer.3 \
+ Net::OpenID::JanRain::Server.3 \
+ Net::OpenID::JanRain::Stores::FileStore.3 \
+ Net::OpenID::JanRain::Stores::MySQLStore.3 \
+ Net::OpenID::JanRain::Stores::PostgreSQLStore.3 \
+ Net::OpenID::JanRain::Stores::SQLStore.3 \
+ Net::OpenID::JanRain::Stores::SQLiteStore.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Net-OpenID-JanRain/distinfo b/security/p5-Net-OpenID-JanRain/distinfo
new file mode 100644
index 000000000000..c19802825c86
--- /dev/null
+++ b/security/p5-Net-OpenID-JanRain/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-OpenID-JanRain-1.1.1.tar.gz) = 90ef0ce43b405cd591dc3de1d819c235
+SHA256 (Net-OpenID-JanRain-1.1.1.tar.gz) = ac35764dc4ddf8f71127674ad15ed85f7336224401c22e4f40720e29b8d99d76
+SIZE (Net-OpenID-JanRain-1.1.1.tar.gz) = 45615
diff --git a/security/p5-Net-OpenID-JanRain/pkg-descr b/security/p5-Net-OpenID-JanRain/pkg-descr
new file mode 100644
index 000000000000..5c9b29e741ba
--- /dev/null
+++ b/security/p5-Net-OpenID-JanRain/pkg-descr
@@ -0,0 +1,14 @@
+OpenID is a decentralized identity system, but one that's actually
+decentralized and doesn't entirely crumble if one company turns evil
+or goes out of business.
+
+An OpenID identity is just a URL. You can have multiple identities in
+the same way you can have multiple URLs. All OpenID does is provide a
+way to prove that you own a URL (identity).
+
+Anybody can run their own site using OpenID, and anybody can be an
+OpenID server, and they all work with each other without having to
+register with or pay anybody to "get started". An owner of a URL can
+pick which OpenID server to use.
+
+WWW: http://www.openidenabled.com/openid/libraries/perl/
diff --git a/security/p5-Net-OpenID-JanRain/pkg-plist b/security/p5-Net-OpenID-JanRain/pkg-plist
new file mode 100644
index 000000000000..899cd41026dc
--- /dev/null
+++ b/security/p5-Net-OpenID-JanRain/pkg-plist
@@ -0,0 +1,23 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/JanRain/.packlist
+%%SITE_PERL%%/Net/OpenID/JanRain/Stores.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/CryptUtil.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Association.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Util.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Consumer.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Server.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Consumer/LinkParser.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Stores/DumbStore.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Stores/FileStore.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Stores/PostgreSQLStore.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Stores/SQLStore.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Stores/MySQLStore.pm
+%%SITE_PERL%%/Net/OpenID/JanRain/Stores/SQLiteStore.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/JanRain/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/JanRain
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/OpenID/JanRain/Stores
+@dirrmtry %%SITE_PERL%%/Net/OpenID/JanRain/Consumer
+@dirrmtry %%SITE_PERL%%/Net/OpenID/JanRain
+@dirrmtry %%SITE_PERL%%/Net/OpenID
+@dirrmtry %%SITE_PERL%%/Net