aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Net-SAML
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-07 07:37:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-07 07:37:14 +0000
commit016df89f559d764a1e6c4db2e76e7849e43b86c8 (patch)
tree637369e1f4a4faef462ea8c41cf8ca2c1d0aec50 /security/p5-Net-SAML
parent18e2902010aaab1a47d1767c2827c5771c73461b (diff)
downloadports-016df89f559d764a1e6c4db2e76e7849e43b86c8.tar.gz
ports-016df89f559d764a1e6c4db2e76e7849e43b86c8.zip
Notes
Diffstat (limited to 'security/p5-Net-SAML')
-rw-r--r--security/p5-Net-SAML/Makefile35
-rw-r--r--security/p5-Net-SAML/distinfo3
-rw-r--r--security/p5-Net-SAML/pkg-descr4
-rw-r--r--security/p5-Net-SAML/pkg-plist11
4 files changed, 53 insertions, 0 deletions
diff --git a/security/p5-Net-SAML/Makefile b/security/p5-Net-SAML/Makefile
new file mode 100644
index 000000000000..4627fa171838
--- /dev/null
+++ b/security/p5-Net-SAML/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Net-SAML
+# Date created: 2007-07-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SAML
+PORTVERSION= 0.22
+CATEGORIES= security perl5
+MASTER_SITES= http://zxid.org/
+PKGNAMEPREFIX= p5-
+DISTNAME= zxid-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for using SAML SSO
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ zxid:${PORTSDIR}/security/zxid
+
+PERL_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/Net
+
+post-patch:
+ ${REINPLACE_CMD} -e 's!/apps/openssl/std!${LOCALBASE}!' \
+ ${WRKSRC}/Makefile.PL
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/../zxid.pl ${EXAMPLESDIR}
+
+MAN3= Net::SAML.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Net-SAML/distinfo b/security/p5-Net-SAML/distinfo
new file mode 100644
index 000000000000..c1e8e510e424
--- /dev/null
+++ b/security/p5-Net-SAML/distinfo
@@ -0,0 +1,3 @@
+MD5 (zxid-0.22.tgz) = 9c7d52080ce3b0111da2bef9513d5c88
+SHA256 (zxid-0.22.tgz) = 052de7fc4cef86ccc1a5526ad89362d52d6ea2afff70594763e7607035fc789e
+SIZE (zxid-0.22.tgz) = 2799246
diff --git a/security/p5-Net-SAML/pkg-descr b/security/p5-Net-SAML/pkg-descr
new file mode 100644
index 000000000000..95470b4f85cc
--- /dev/null
+++ b/security/p5-Net-SAML/pkg-descr
@@ -0,0 +1,4 @@
+A Perl module wrapping libzxid. Also zxid.pl, that implements SP in
+mod_perl environment, is supplied.
+
+WWW: http://zxid.org/
diff --git a/security/p5-Net-SAML/pkg-plist b/security/p5-Net-SAML/pkg-plist
new file mode 100644
index 000000000000..e667c29b6c18
--- /dev/null
+++ b/security/p5-Net-SAML/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%EXAMPLESDIR%%/zxid.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/SAML.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/SAML.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SAML/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SAML/SAML.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SAML/SAML.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SAML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Net
+@dirrmtry %%EXAMPLESDIR%%